# CVE-2026-94612: authentik: Authentication bypass via assertion confusion in SAML sources

> An unauthenticated attacker can bypass authentication in authentik SAML sources by reusing or misdirecting valid assertions, leading to account takeover.

- **Severity:** High 7.4 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** BIT-authentik-2026-94612, GHSA-cqj8-fxxf-9pg7

## What is CVE-2026-94612?

CVE-2026-94612 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an authentik SAML Source verifies an assertion's signature and validity period but does not ensure that the identity provider issued the assertion for that Source or in response to a login request from that Source. The SAML Source also does not record already accepted assertions, allowing replay. An unauthenticated actor who possesses such a valid assertion can use an assertion intended for another service provider or reuse an earlier assertion to authenticate as the user named by the assertion. Only SAML Sources are affected; SAML Providers and other Source types are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.

Weakness: CWE-345 (Insufficient Verification of Data Authenticity), CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-94612?

1 open source package ship an affected version, including authentik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |

## How do I fix CVE-2026-94612?

Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.

## Is CVE-2026-94612 being exploited?

There is no known exploitation of CVE-2026-94612 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94612 and fix it if it is affected.

What it is: CVE-2026-94612 is a high-severity authentication bypass vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94612 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94612/ (Markdown: https://insights.sbomify.com/CVE-2026-94612/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94612
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94612
- OSV: https://osv.dev/vulnerability/CVE-2026-94612

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94612/
Summaries are generated and may contain mistakes; the official description above is the record.
