CVE-2026-94613 authentik: Denial of Service via Document Type Declarations in SAML Messages
Unauthenticated attackers can cause denial of service in authentik by sending malformed SAML messages that crash worker processes.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94613?
CVE-2026-94613 is a high-severity denial of service vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an unauthenticated attacker can submit a malformed SAML message to an authentik deployment using SAML in either the identity-provider or SAML source role. The message can stop the worker handling /application/saml/* or /source/saml/*, causing the requests assigned to that worker to fail. Worker process termination and automatic restart do not destroy database-backed sessions, but continued malicious messages can cause a sustained share of legitimate traffic to fail. Other protocol implementations are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.
Weakness: CWE-770
Which versions are affected by CVE-2026-94613?
1 open source package ship an affected version, including authentik.
| Package | Affected | Fixed in |
|---|---|---|
authentik Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |
How do I fix CVE-2026-94613?
Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-94613 being exploited?
There is no known exploitation of CVE-2026-94613 in the wild and no public exploit code.
Sources
Also known as BIT-authentik-2026-94613, GHSA-cxwx-9x59-28qm.