{"answers":{"affected":"1 open source package ship an affected version, including authentik.","exploited":"There is no known exploitation of CVE-2026-94613 in the wild and no public exploit code.","fix":"Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.","what":"CVE-2026-94613 is a high-severity denial of service vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-94613 and fix it if it is affected.\n\nWhat it is: CVE-2026-94613 is a high-severity denial of service vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-94613 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-94613/ (Markdown: https://insights.sbomify.com/CVE-2026-94613/index.md)","id":"CVE-2026-94613","markdown":"https://insights.sbomify.com/CVE-2026-94613/index.md","name":"CVE-2026-94613","record":{"aliases":["BIT-authentik-2026-94613","GHSA-cxwx-9x59-28qm"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Identity provider","requires_auth":"none","summary":"Unauthenticated attackers can cause denial of service in authentik by sending malformed SAML messages that crash worker processes.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-770","name":"Allocation of Resources Without Limits or Throttling"}],"description":"authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an unauthenticated attacker can submit a malformed SAML message to an authentik deployment using SAML in either the identity-provider or SAML source role. The message can stop the worker handling /application/saml/* or /source/saml/*, causing the requests assigned to that worker to fail. Worker process termination and automatic restart do not destroy database-backed sessions, but continued malicious messages can cause a sustained share of legitimate traffic to fail. Other protocol implementations are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"authentik: Denial of Service via Document Type Declarations in SAML Messages","id":"CVE-2026-94613","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"denial_of_service","year":"2026"},"n_packages":1,"n_references":15,"next":{"headline":"Path traversal in classroom50","id":"CVE-2026-94620"},"packages":[{"ecosystem":"Bitnami","fixed":["2026.2.7","2026.5.7","2026.8.2"],"introduced":["0","2026.5.0","2026.8.0"],"last_affected":[],"package":"authentik","purl":"pkg:bitnami/authentik","source":"BIT-authentik-2026-94613"}],"prev":{"headline":"authentik: Authentication bypass via assertion confusion in SAML sources","id":"CVE-2026-94612"},"products":["authentik"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"yes","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-29","vendors":["goauthentik"]},"summary":"Unauthenticated attackers can cause denial of service in authentik by sending malformed SAML messages that crash worker processes.","url":"https://insights.sbomify.com/CVE-2026-94613/"}