# CVE-2026-94613: authentik: Denial of Service via Document Type Declarations in SAML Messages

> Unauthenticated attackers can cause denial of service in authentik by sending malformed SAML messages that crash worker processes.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 29 Sep 2026
- **Also known as:** BIT-authentik-2026-94613, GHSA-cxwx-9x59-28qm

## What is CVE-2026-94613?

CVE-2026-94613 is a high-severity denial of service vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

authentik is an open-source identity provider. Prior to 2026.2.7, 2026.5.7, and 2026.8.2, an unauthenticated attacker can submit a malformed SAML message to an authentik deployment using SAML in either the identity-provider or SAML source role. The message can stop the worker handling /application/saml/* or /source/saml/*, causing the requests assigned to that worker to fail. Worker process termination and automatic restart do not destroy database-backed sessions, but continued malicious messages can cause a sustained share of legitimate traffic to fail. Other protocol implementations are not affected. This issue is fixed in versions 2026.2.7, 2026.5.7, and 2026.8.2.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-94613?

1 open source package ship an affected version, including authentik.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authentik` | Bitnami | All versions | 2026.2.7, 2026.5.7, 2026.8.2 |

## How do I fix CVE-2026-94613?

Upgrade authentik to a fixed version for your release line: 2026.2.7, 2026.5.7 or 2026.8.2.

## Is CVE-2026-94613 being exploited?

There is no known exploitation of CVE-2026-94613 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94613 and fix it if it is affected.

What it is: CVE-2026-94613 is a high-severity denial of service vulnerability in goauthentik authentik, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94613 in the wild and no public exploit code.

Affected packages and fixed versions:
- authentik (Bitnami): affected all versions; fixed in 2026.2.7, 2026.5.7, 2026.8.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94613/ (Markdown: https://insights.sbomify.com/CVE-2026-94613/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94613
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94613
- OSV: https://osv.dev/vulnerability/CVE-2026-94613

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94613/
Summaries are generated and may contain mistakes; the official description above is the record.
