CVE-2026-94624 vLLM through 0.29.0 Denial of Service via Unbounded P2P KV Offloading Sessions
Attackers can crash the vLLM inference engine by exhausting ZeroMQ sockets via malicious peer parameters in specific offloading configurations.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-94624?
CVE-2026-94624 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroMQ sockets until the context quota is exhausted, causing an uncaught ZMQError that crashes EngineCore and stops all inference.
Weakness: CWE-770
Which versions are affected by CVE-2026-94624?
3 open source packages ship an affected version, including vllm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
vllm PyPI | All versions | 0.30.0 |
vllm PyPI | All versions | 0.32.0 |
vllm PyPI | All versions | 0.32.0 |
Products include Vllm Vllm.
How do I fix CVE-2026-94624?
Upgrade vllm to a fixed version for your release line: 0.30.0 or 0.32.0.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-94624 being exploited?
There is no known exploitation of CVE-2026-94624 in the wild and no public exploit code.
Other vulnerabilities in Vllm Vllm
- CVE-2025-32444 vLLM Vulnerable to Remote Code Execution via Mooncake Integration
- CVE-2026-22778 vLLM leaks a heap address when PIL throws an error
- CVE-2025-47277 vLLM Allows Remote Code Execution via PyNcclPipe Communication Service
- CVE-2024-11041 Remote Code Execution in vllm-project/vllm
- CVE-2026-48746 vLLM: OpenAI auth bypass
Sources
Also known as GHSA-frvg-qw88-hww9, MINI-2c7h-jqmm-88r7, MINI-6hwp-8f27-vpgq, MINI-mx43-54wj-vvjv, PYSEC-2026-4006.