# CVE-2026-94624: vLLM through 0.29.0 Denial of Service via Unbounded P2P KV Offloading Sessions

> Attackers can crash the vLLM inference engine by exhausting ZeroMQ sockets via malicious peer parameters in specific offloading configurations.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 21 Sep 2026
- **Updated:** 22 Sep 2026
- **Also known as:** GHSA-frvg-qw88-hww9, MINI-2c7h-jqmm-88r7, MINI-6hwp-8f27-vpgq, MINI-mx43-54wj-vvjv, PYSEC-2026-4006

## What is CVE-2026-94624?

CVE-2026-94624 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

vLLM through 0.29.0 contains a denial of service vulnerability in P2P KV offloading when OffloadingConnector is configured with TieringOffloadingSpec and a peer-to-peer secondary tier. Attackers can supply arbitrary remote host and port values in kv_transfer_params to create unreachable peer sessions that retain ZeroMQ sockets until the context quota is exhausted, causing an uncaught ZMQError that crashes EngineCore and stops all inference.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling)

## Which versions are affected by CVE-2026-94624?

3 open source packages ship an affected version, including vllm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `vllm` | PyPI | All versions | 0.30.0 |
| `vllm` | PyPI | All versions | 0.32.0 |
| `vllm` | PyPI | All versions | 0.32.0 |

Products: Vllm Vllm.

## How do I fix CVE-2026-94624?

Upgrade vllm to a fixed version for your release line: 0.30.0 or 0.32.0.

## Is CVE-2026-94624 being exploited?

There is no known exploitation of CVE-2026-94624 in the wild and no public exploit code.

## Other vulnerabilities in Vllm Vllm

- [CVE-2025-32444](https://insights.sbomify.com/CVE-2025-32444/): vLLM Vulnerable to Remote Code Execution via Mooncake Integration (critical 10.0)
- [CVE-2026-22778](https://insights.sbomify.com/CVE-2026-22778/): vLLM leaks a heap address when PIL throws an error (critical 9.8)
- [CVE-2025-47277](https://insights.sbomify.com/CVE-2025-47277/): vLLM Allows Remote Code Execution via PyNcclPipe Communication Service (critical 9.8)
- [CVE-2024-11041](https://insights.sbomify.com/CVE-2024-11041/): Remote Code Execution in vllm-project/vllm (critical 9.8)
- [CVE-2026-48746](https://insights.sbomify.com/CVE-2026-48746/): vLLM: OpenAI auth bypass (critical 9.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94624 and fix it if it is affected.

What it is: CVE-2026-94624 is a high-severity denial of service vulnerability in Vllm Vllm, published on 21 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94624 in the wild and no public exploit code.

Affected packages and fixed versions:
- vllm (PyPI): affected all versions; fixed in 0.30.0
- vllm (PyPI): affected all versions; fixed in 0.32.0
- vllm (PyPI): affected all versions; fixed in 0.32.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94624/ (Markdown: https://insights.sbomify.com/CVE-2026-94624/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94624
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94624
- OSV: https://osv.dev/vulnerability/CVE-2026-94624

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94624/
Summaries are generated and may contain mistakes; the official description above is the record.
