# CVE-2026-94650: Apache Thrift: c_glib generated struct readers have no recursion-depth guard (native stack exhaustion)

> Attackers can cause native stack exhaustion and denial of service in applications using Apache Thrift c_glib bindings by sending deeply nested structures.

- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-106602, BIT-thrift-2026-94650, DEBIAN-CVE-2026-94650, ECHO-c545-33ef-e2cb, GHSA-hhg4-p43g-gfq2, MINI-7hh8-fv8h-fcxq, UBUNTU-CVE-2026-94650

## What is CVE-2026-94650?

CVE-2026-94650 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Uncontrolled Recursion vulnerability in Apache Thrift c_glib bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-674 (Uncontrolled Recursion)

## Which versions are affected by CVE-2026-94650?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-94650?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-94650 being exploited?

There is no known exploitation of CVE-2026-94650 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-94650 and fix it if it is affected.

What it is: CVE-2026-94650 is a high-severity denial of service vulnerability in Apache Thrift, published on 2 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-94650 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-94650/ (Markdown: https://insights.sbomify.com/CVE-2026-94650/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-94650
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-94650
- OSV: https://osv.dev/vulnerability/CVE-2026-94650

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-94650/
Summaries are generated and may contain mistakes; the official description above is the record.
