# CVE-2026-9495: @koa/router has an Access Control Bypass

> Attackers can bypass authentication, authorization, or rate limiting by exploiting a flaw where middleware is silently dropped when router prefixes contain path parameters.

- **Severity:** Medium 6.9 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 May 2026
- **Updated:** 26 May 2026
- **Also known as:** GHSA-47p6-69vm-vw6v

## What is CVE-2026-9495?

CVE-2026-9495 is a medium-severity authentication bypass vulnerability in @koa/router, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions of the package @koa/router from 14.0.0 and before 15.0.0 are vulnerable to Access Control Bypass due to the middleware being silently dropped from the execution chain when the router prefix contains path parameters. Depending on what the skipped middleware was supposed to protect, an attacker could bypass authentication and authorization, evade rate limiting or bypass input sanitization.

Weakness: CWE-284 (Improper Access Control)

## Which versions are affected by CVE-2026-9495?

2 open source packages ship an affected version, including @koa/router.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@koa/router` | npm | From 14.0.0 | 15.0.0 |
| `@koa/router` | npm | From 14.0.0 | 15.0.0 |

## How do I fix CVE-2026-9495?

Upgrade @koa/router to 15.0.0 or later.

## Is CVE-2026-9495 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9495 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9495 and fix it if it is affected.

What it is: CVE-2026-9495 is a medium-severity authentication bypass vulnerability in @koa/router, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9495 exists.

Affected packages and fixed versions:
- @koa/router (npm): affected from 14.0.0; fixed in 15.0.0
- @koa/router (npm): affected from 14.0.0; fixed in 15.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9495/ (Markdown: https://insights.sbomify.com/CVE-2026-9495/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9495
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9495
- OSV: https://osv.dev/vulnerability/CVE-2026-9495

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9495/
Summaries are generated and may contain mistakes; the official description above is the record.
