CVE-2026-9496 pacote is vulnerable to Denial of Service (DoS) via the addGitSha function
An attacker can cause denial of service in the pacote library by supplying a crafted spec value that triggers excessive CPU consumption.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-9496?
CVE-2026-9496 is a high-severity denial of service vulnerability in org.webjars.npm:pacote, published on 26 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Versions of the package pacote from 11.2.7 and before 21.5.1 are vulnerable to Denial of Service (DoS) via the addGitSha function. An attacker can exploit this vulnerability by supplying a specially crafted spec.rawSpec value that triggers the function’s regex replacement and string-manipulation logic, causing excessive CPU consumption and potentially stalling or crashing the process.
Which versions are affected by CVE-2026-9496?
2 open source packages ship an affected version, including pacote.
| Package | Affected | Fixed in |
|---|---|---|
pacote npm | From 11.2.7 | 21.5.1 |
pacote npm | From 11.2.7 | 21.5.1 |
Linux distribution packages (1)
grafana12.4 Red Hat:hummingbird:1 | All versions | 0:12.4.10-0.8.hum1 |
How do I fix CVE-2026-9496?
Upgrade pacote to 21.5.1 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-9496 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9496 exists.
Sources
Also known as CLEANSTART-2026-AI21372, CLEANSTART-2026-HY69996, CLEANSTART-2026-QH29658, CLSA-2026-1787859798, CLSA-2026-1787916402, CLSA-2026-1788781526 and 22 more.