{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9539 exists.","fix":"Upgrade to a fixed version.","what":"CVE-2026-9539 is a medium-severity vulnerability in freedesktop.org libslirp, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-9539 and fix it if it is affected.\n\nWhat it is: CVE-2026-9539 is a medium-severity vulnerability in freedesktop.org libslirp, published on 24 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-9539 exists.\n\nAffected product: freedesktop.org libslirp. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9539/ (Markdown: https://insights.sbomify.com/CVE-2026-9539/index.md)","id":"CVE-2026-9539","markdown":"https://insights.sbomify.com/CVE-2026-9539/index.md","name":"CVE-2026-9539","record":{"aliases":["AZL-90912","BELL-CVE-2026-9539","DEBIAN-CVE-2026-9539","GHSA-4243-hp56-4m7f","MGASA-2026-0306","SUSE-SU-2026:22452-1","SUSE-SU-2026:22514-1","SUSE-SU-2026:2886-1","SUSE-SU-2026:2931-1","UBUNTU-CVE-2026-9539","USN-8550-1","openSUSE-SU-2026:11134-1","openSUSE-SU-2026:21216-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"libslirp networking library","requires_auth":"low_privilege","summary":"A privileged guest VM attacker can leak host heap memory via crafted TCP segments in libslirp, impacting hypervisor hosts like QEMU.","user_interaction":"not_required","vuln_class":"information_disclosure"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"STAR_Labs","cpe":[],"cvss":{"score":6.5,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-125","name":"Out-of-bounds Read"}],"description":"An out-of-bounds heap read and integer underflow in the TCP urgent data handling (sosendoob) in freedesktop.org libslirp version before v4.9.2 on hypervisor host environments (e.g., QEMU) allows a privileged guest VM attacker (root or CAP_NET_RAW) to leak gigabytes of sensitive host-process heap memory via sending crafted TCP segments with manipulated URG flags and urgent pointers (ti_urp).","ecosystems":["SUSE:Linux Enterprise Micro 5.3","SUSE:Linux Enterprise Micro 5.4","SUSE:Linux Enterprise Micro 5.5","SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Micro 6.0","SUSE:Linux Micro 6.1","openSUSE:Leap 16.0","openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":"2026-10-19","github_poc":1,"max_poc_stars":1,"metasploit":0,"nuclei":0,"refs":[{"date":"2026-10-19T09:08:22Z","kind":"github_poc","ref":"https://github.com/quarkslab/slirp_snapshots_stateful","stars":1,"title":"PoC for the «Snapshotting our way to CVE-2026-9539» blogpost"}],"tier":"weaponised"},"has_fix":true,"headline":"libslirp TCP URG OOB Read Information Leak","id":"CVE-2026-9539","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"information_disclosure","year":"2026"},"n_packages":8,"n_references":3,"next":{"headline":"vllm-project vllm OpenAI-compatible Serving Path denial of service","id":"CVE-2026-9540"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Micro 5.3","fixed":["4.7.0+44-150300.18.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.3","source":"SUSE-SU-2026:2886-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["4.7.0+44-150300.18.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2026:2886-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["4.7.0+44-150500.4.3.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2026:2931-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["4.7.0+44-150500.4.3.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:2931-1"},{"ecosystem":"SUSE:Linux Micro 6.0","fixed":["4.7.0+44-5.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Micro%206.0","source":"SUSE-SU-2026:22514-1"},{"ecosystem":"SUSE:Linux Micro 6.1","fixed":["4.8.0+2-slfo.1.1_2.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/suse/libslirp\u0026distro=SUSE%20Linux%20Micro%206.1","source":"SUSE-SU-2026:22452-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["4.8.0+2-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/opensuse/libslirp\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21216-1"},{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.9.3+4-1.1"],"introduced":["0"],"last_affected":[],"package":"libslirp","purl":"pkg:rpm/opensuse/libslirp\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11134-1"}],"prev":{"headline":"Denial of service in Archive::Tar","id":"CVE-2026-9538"},"products":["libslirp"],"published":"2026-06-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"},{"class":"open","licence":"CC0","name":"PoC-in-GitHub"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-06-24","vendors":["freedesktop.org"]},"summary":"A privileged guest VM attacker can leak host heap memory via crafted TCP segments in libslirp, impacting hypervisor hosts like QEMU.","url":"https://insights.sbomify.com/CVE-2026-9539/"}