# CVE-2026-9557: Mautic Focus component Vulnerable to SSRF

> Authenticated users can exploit insufficient URL validation in Mautic's Focus component to perform Server-Side Request Forgery, enabling internal network reconnaissance.

- **Severity:** Medium 6.4 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-jmv8-8j9j-rcpc

## What is CVE-2026-9557?

CVE-2026-9557 is a medium-severity server-side request forgery vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A Server-Side Request Forgery (SSRF) vulnerability exists in Mautic's Focus component. Due to insufficient validation of user-supplied URLs, an authenticated user can trigger outbound HTTP requests from the hosting server, enabling internal network reconnaissance or forcing requests to arbitrary internal or external destinations.

Weakness: CWE-918 (Server-Side Request Forgery)

## Which versions are affected by CVE-2026-9557?

8 open source packages ship an affected version, including mautic/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | From 4.0.0 to 4.4.13 | None |
| `mautic/core` | Packagist | From 4.0.0 to 4.4.13 | None |
| `mautic/core` | Packagist | From 5.0.0 | 5.2.11 |
| `mautic/core` | Packagist | From 5.0.0 | 5.2.11 |
| `mautic/core` | Packagist | From 6.0.0 | 6.0.9 |
| `mautic/core` | Packagist | From 6.0.0 | 6.0.9 |
| `mautic/core` | Packagist | From 7.0.0 | 7.1.2 |
| `mautic/core` | Packagist | From 7.0.0 | 7.1.2 |

## How do I fix CVE-2026-9557?

Upgrade mautic/core to a fixed version for your release line: 5.2.11, 6.0.9 or 7.1.2.

## Is CVE-2026-9557 being exploited?

There is no known exploitation of CVE-2026-9557 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9557 and fix it if it is affected.

What it is: CVE-2026-9557 is a medium-severity server-side request forgery vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9557 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected from 4.0.0 up to 4.4.13; no fix listed
- mautic/core (Packagist): affected from 4.0.0 up to 4.4.13; no fix listed
- mautic/core (Packagist): affected from 5.0.0; fixed in 5.2.11
- mautic/core (Packagist): affected from 5.0.0; fixed in 5.2.11
- mautic/core (Packagist): affected from 6.0.0; fixed in 6.0.9
- mautic/core (Packagist): affected from 6.0.0; fixed in 6.0.9
- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2
- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9557/ (Markdown: https://insights.sbomify.com/CVE-2026-9557/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9557
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9557
- OSV: https://osv.dev/vulnerability/CVE-2026-9557

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9557/
Summaries are generated and may contain mistakes; the official description above is the record.
