{"answers":{"affected":"2 open source packages ship an affected version, including mautic/core.","exploited":"There is no known exploitation of CVE-2026-9559 in the wild and no public exploit code.","fix":"Upgrade mautic/core to 7.1.2 or later.","what":"CVE-2026-9559 is a critical path traversal vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-9559 and fix it if it is affected.\n\nWhat it is: CVE-2026-9559 is a critical path traversal vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-9559 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2\n- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9559/ (Markdown: https://insights.sbomify.com/CVE-2026-9559/index.md)","id":"CVE-2026-9559","markdown":"https://insights.sbomify.com/CVE-2026-9559/index.md","name":"CVE-2026-9559","record":{"aliases":["GHSA-6r9h-4h75-7q4x"],"analysis":{"component_type":"web_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Mautic marketing automation","requires_auth":"low_privilege","summary":"Authenticated users can exploit path traversal in campaign imports to write arbitrary PHP files, leading to remote code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"Mautic","cpe":[],"cvss":{"score":9.9,"severity":"critical","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-98","name":"Improper Control of Filename for Include/Require Statement in PHP Program"},{"id":"CWE-73","name":"External Control of File Name or Path"},{"id":"CWE-22","name":"Improper Limitation of a Pathname to a Restricted Directory"}],"description":"A path traversal vulnerability exists in the campaign import feature of Mautic 7. When extracting uploaded ZIP files during campaign imports, a flaw in the validation logic allows file paths to escape the intended temporary directories. An authenticated user with campaign import privileges (campaign:imports:create) can write arbitrary PHP files to sensitive system directories. An attacker can exploit this to overwrite critical internal configuration or cache components, resulting in Remote Code Execution (RCE) under the context of the web server user.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Mautic vulnerable to Path Traversal via Campaign Import","id":"CVE-2026-9559","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"path_traversal","year":"2026"},"n_packages":2,"n_references":1,"next":{"headline":"Privilege escalation in OpenVPN Connect","id":"CVE-2026-9560"},"packages":[{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"mautic/core","purl":null,"source":"GHSA-6r9h-4h75-7q4x"},{"ecosystem":"Packagist","fixed":["7.1.2"],"introduced":["7.0.0"],"last_affected":[],"package":"mautic/core","purl":"pkg:composer/mautic/core","source":"GHSA-6r9h-4h75-7q4x"}],"prev":{"headline":"Mautic has Server-Side Template Injection (SSTI) in Theme Templates","id":"CVE-2026-9558"},"products":[],"published":"2026-05-29","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-05-29","vendors":[]},"summary":"Authenticated users can exploit path traversal in campaign imports to write arbitrary PHP files, leading to remote code execution.","url":"https://insights.sbomify.com/CVE-2026-9559/"}