{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-95660 exists.","fix":"No fix has been published for CVE-2026-95660 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-95660 is a medium-severity command injection vulnerability in Moonshot AI Kimi Code, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-95660 and fix it if it is affected.\n\nWhat it is: CVE-2026-95660 is a medium-severity command injection vulnerability in Moonshot AI Kimi Code, published on 22 Sep 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-95660 exists.\n\nAffected product: Moonshot AI Kimi Code. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-95660/ (Markdown: https://insights.sbomify.com/CVE-2026-95660/index.md)","id":"CVE-2026-95660","markdown":"https://insights.sbomify.com/CVE-2026-95660/index.md","name":"CVE-2026-95660","record":{"aliases":["GHSA-jp7p-97jq-v89h"],"analysis":{"component_type":"developer_tool","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Kimi Code MCP loader","requires_auth":"none","summary":"Remote attackers can execute arbitrary OS commands via untrusted MCP configuration files in Kimi Code, requiring an upgrade to mitigate.","user_interaction":"required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":5.3,"severity":"medium","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"},{"id":"CWE-77","name":"Improper Neutralization of Special Elements used in a Command"}],"description":"A security flaw has been discovered in Moonshot AI Kimi Code up to 0.31.0. The affected element is an unknown function of the file agent-core-v2/src/agent/mcp/config-loader.ts of the component MCP Configuration Loader. The manipulation results in os command injection. The attack may be launched remotely. The exploit has been released to the public and may be used for attacks. Upgrading to version 0.31.1 is sufficient to fix this issue. It is recommended to upgrade the affected component. Beyond the trust prompt, the fix resolves fd/stty binaries to absolute paths specifically \"so untrusted workspaces cannot plant bare-name executables before confirmation,\" fixing a secondary $PATH path-planting vector alongside the primary untrusted-.mcp.json auto-spawn.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"Moonshot AI Kimi Code MCP Configuration Loader config-loader.ts os command injection","id":"CVE-2026-95660","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":6,"next":{"headline":"MISP Reflected Cross-Site Scripting in Attribute Histogram via Unescaped URL-Supplied Type List","id":"CVE-2026-95661"},"packages":[],"prev":{"headline":"MISP Reflected XSS via Unvalidated Object Type in AnalystData Overmind Thread","id":"CVE-2026-95659"},"products":["Kimi Code"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-22","vendors":["Moonshot AI"]},"summary":"Remote attackers can execute arbitrary OS commands via untrusted MCP configuration files in Kimi Code, requiring an upgrade to mitigate.","url":"https://insights.sbomify.com/CVE-2026-95660/"}