CVE-2026-95838 containerd: Unpack DoS via repeated opaque whiteouts
A malicious image layer can cause excessive CPU consumption and delayed startup in containerd by triggering repeated directory traversals during unpacking.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Local or same network only
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2026-95838?
CVE-2026-95838 is a medium-severity denial of service vulnerability in containerd, published on 12 Oct 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Official description
containerd is an open-source container runtime. Prior to 1.7.35, 2.0.12, 2.2.8, and 2.3.5, containerd's layer unpack handler repeatedly traverses directories for certain opaque whiteout configurations. A malicious image layer can trigger repeated directory traversals while opaque whiteouts are processed. Pulling or importing the image can consume CPU, delay container startup, and reduce image-pull concurrency for unrelated deployments. This issue is fixed in versions 1.7.35, 2.0.12, 2.2.8, and 2.3.5.
Which versions are affected by CVE-2026-95838?
10 open source packages ship an affected version, including github.com/containerd/containerd/v2 and github.com/containerd/containerd.
| Package | Affected | Fixed in |
|---|---|---|
github.com/containerd/containerd/v2 Go | All versions | 2.0.12, 2.2.8, 2.3.5 |
github.com/containerd/containerd/v2 Go | All versions | 2.0.12 |
github.com/containerd/containerd/v2 Go | All versions | 2.0.12 |
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.8 |
github.com/containerd/containerd/v2 Go | From 2.2.0 | 2.2.8 |
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.5 |
4 more packages
github.com/containerd/containerd/v2 Go | From 2.3.0 | 2.3.5 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
github.com/containerd/containerd Go | All versions | 1.7.35 |
How do I fix CVE-2026-95838?
Upgrade github.com/containerd/containerd/v2 to a fixed version for your release line: 2.0.12, 2.2.8 or 2.3.5.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-95838 being exploited?
There is no known exploitation of CVE-2026-95838 in the wild and no public exploit code.
Sources
Also known as AZL-108008, AZL-108053, AZL-108068, AZL-108072, AZL-108075, AZL-108078 and 303 more.