# CVE-2026-9595: webpack-dev-server vulnerable to HMR WebSocket interception via permissive user proxies

> Misconfigured proxies in webpack-dev-server leak cookies and bypass origin checks by intercepting HMR WebSockets, requiring scoped proxy contexts or disabling WebSocket forwarding.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Jun 2026
- **Updated:** 15 Jun 2026
- **Also known as:** CLEANSTART-2026-UI84742, CLSA-2026-1787837620, GHSA-mx8g-39q3-5c79, MINI-22f4-5pgw-hff5, MINI-g5x9-2hrg-8v6r, MINI-j9cf-gq4v-9jfc, MINI-jhjw-hgxv-qcrw, MINI-phj2-mg9m-236q, MINI-r86j-vxcp-g58q, ROOT-APP-NPM-CVE-2026-9595, UBUNTU-CVE-2026-9595

## What is CVE-2026-9595?

CVE-2026-9595 is a medium-severity vulnerability in webpack-dev-server, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact: When a user-configured proxy on webpack-dev-server has a broad context (e.g. /) and ws: true, it also intercepts the dev server's own HMR WebSocket and forwards it to the proxy target. This leaks the browser's cookies and Origin header to the backend, bypasses the dev server's Host/Origin validation, and corrupts the HMR socket (both HMR and the proxy end up writing to the same socket).

Patches: Fixed in webpack-dev-server@5.2.5.

Workarounds: Scope user-defined proxy context to specific paths instead of /, or omit ws: true from the proxy entry when WebSocket forwarding is not required.

Weakness: CWE-441 (Unintended Proxy or Intermediary), CWE-346 (Origin Validation Error)

## Which versions are affected by CVE-2026-9595?

2 open source packages ship an affected version, including webpack-dev-server. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `webpack-dev-server` | npm | All versions | 5.2.5 |
| `webpack-dev-server` | npm | All versions | 5.2.5 |

Products: Webpack.js Webpack-Dev-Server.

## How do I fix CVE-2026-9595?

Upgrade webpack-dev-server to 5.2.5 or later.

## Is CVE-2026-9595 being exploited?

There is no known exploitation of CVE-2026-9595 in the wild and no public exploit code.

## Other vulnerabilities in webpack-dev-server

- [CVE-2026-112085](https://insights.sbomify.com/CVE-2026-112085/): webpack-dev-server vulnerable to cross-origin WebSocket access via proxied upgrades (high 8.2)
- [CVE-2018-14732](https://insights.sbomify.com/CVE-2018-14732/): Missing Origin Validation in webpack-dev-server (high 7.5)
- [CVE-2025-30360](https://insights.sbomify.com/CVE-2025-30360/): webpack-dev-server users' source code may be stolen when they access a malicious web site with non-Chromium based browser (medium 6.5)
- [CVE-2026-114348](https://insights.sbomify.com/CVE-2026-114348/): webpack-dev-server vulnerable to information disclosure via Host validation bypass in the open-editor endpoint (medium 5.3)
- [CVE-2026-14631](https://insights.sbomify.com/CVE-2026-14631/): webpack-dev-server vulnerable to denial of service via a malformed Host or Origin header (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9595 and fix it if it is affected.

What it is: CVE-2026-9595 is a medium-severity vulnerability in webpack-dev-server, published on 15 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9595 in the wild and no public exploit code.

Affected packages and fixed versions:
- webpack-dev-server (npm): affected all versions; fixed in 5.2.5
- webpack-dev-server (npm): affected all versions; fixed in 5.2.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9595/ (Markdown: https://insights.sbomify.com/CVE-2026-9595/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9595
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9595
- OSV: https://osv.dev/vulnerability/CVE-2026-9595

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9595/
Summaries are generated and may contain mistakes; the official description above is the record.
