{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-96269 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2026-96269 is a high-severity code injection vulnerability in GNU Emacs, published on 22 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-96269 and fix it if it is affected.\n\nWhat it is: CVE-2026-96269 is a high-severity code injection vulnerability in GNU Emacs, published on 22 Sep 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-96269 in the wild and no public exploit code.\n\nAffected product: GNU Emacs. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-96269/ (Markdown: https://insights.sbomify.com/CVE-2026-96269/index.md)","id":"CVE-2026-96269","markdown":"https://insights.sbomify.com/CVE-2026-96269/index.md","name":"CVE-2026-96269","record":{"aliases":["ALSA-2026:90887","AZL-103410","DEBIAN-CVE-2026-96269","GHSA-29x7-3q83-3x3v","RLSA-2026:90887","UBUNTU-CVE-2026-96269"],"analysis":{"component_type":"desktop_application","fix_type":"patch","impacts":["code_execution"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"GNU Emacs editor","requires_auth":"none","summary":"Attackers can execute arbitrary code by tricking users into opening a malicious file in GNU Emacs due to unsafe symbol handling.","user_interaction":"not_required","vuln_class":"code_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[],"cvss":{"score":7.5,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-829","name":"Inclusion of Functionality from Untrusted Control Sphere"}],"description":"GNU Emacs 28.1 through 31.1 allows arbitrary code execution upon opening a file, because an untrusted value of read-symbol-shorthands affects the intern and unintern functions. This affects the default configuration; no particular user settings are required to trigger it.","ecosystems":["AlmaLinux:10","Rocky Linux:10"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Code injection in Emacs","id":"CVE-2026-96269","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"code_injection","year":"2026"},"n_packages":6,"n_references":2,"next":{"headline":"Ultimate Member \u003c= 2.13.1 - Unauthenticated Stored Cross-Site Scripting via 'form_id' Parameter","id":"CVE-2026-96270"},"packages":[{"ecosystem":"AlmaLinux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs","purl":"pkg:rpm/almalinux/emacs","source":"ALSA-2026:90887"},{"ecosystem":"AlmaLinux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs-common","purl":"pkg:rpm/almalinux/emacs-common","source":"ALSA-2026:90887"},{"ecosystem":"AlmaLinux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs-filesystem","purl":"pkg:rpm/almalinux/emacs-filesystem","source":"ALSA-2026:90887"},{"ecosystem":"AlmaLinux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs-lucid","purl":"pkg:rpm/almalinux/emacs-lucid","source":"ALSA-2026:90887"},{"ecosystem":"AlmaLinux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs-nw","purl":"pkg:rpm/almalinux/emacs-nw","source":"ALSA-2026:90887"},{"ecosystem":"Rocky Linux:10","fixed":["1:29.4-14.el10_2.4"],"introduced":["0"],"last_affected":[],"package":"emacs","purl":"pkg:rpm/rocky-linux/emacs?distro=rocky-linux-10\u0026epoch=1","source":"RLSA-2026:90887"}],"prev":{"headline":"Cross-site scripting in Awesome Support – WordPress HelpDesk \u0026 Support Plugin","id":"CVE-2026-96268"},"products":["Emacs"],"published":"2026-09-22","related":[],"sources":[{"class":"attribution","licence":"MIT","name":"AlmaLinux","prefix":"ALSA"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"BSD","name":"Rocky Linux","prefix":"RLSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["GNU"]},"summary":"Attackers can execute arbitrary code by tricking users into opening a malicious file in GNU Emacs due to unsafe symbol handling.","url":"https://insights.sbomify.com/CVE-2026-96269/"}