# CVE-2026-96292: Apache Thrift: Lua `THttpTransport:_parseHeaders` matches each header line with a backtracking pattern (quadratic)


- **Severity:** High 8.2 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 2 Oct 2026
- **Updated:** 2 Oct 2026
- **Also known as:** AZL-106614, BIT-thrift-2026-96292, DEBIAN-CVE-2026-96292, GHSA-c9g6-hvjw-wvmp, MINI-5p3q-vg26-qvrw, UBUNTU-CVE-2026-96292

## What is CVE-2026-96292?

CVE-2026-96292 is a high-severity vulnerability in Apache Thrift, published on 2 Oct 2026. 

### Official description

Inefficient regular expression complexity, Inefficient Algorithmic Complexity vulnerability in Apache Thrift Lua bindings.

This issue affects Apache Thrift: before 0.25.0.

Users are recommended to upgrade to version 0.25.0, which fixes the issue.

Weakness: CWE-407 (Inefficient Algorithmic Complexity), CWE-1333 (Inefficient Regular Expression Complexity)

## Which versions are affected by CVE-2026-96292?

1 open source package ship an affected version, including thrift.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.25.0 |

## How do I fix CVE-2026-96292?

Upgrade thrift to 0.25.0 or later.

## Is CVE-2026-96292 being exploited?

There is no known exploitation of CVE-2026-96292 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96292 and fix it if it is affected.

What it is: CVE-2026-96292 is a high-severity vulnerability in Apache Thrift, published on 2 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-96292 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.25.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96292/ (Markdown: https://insights.sbomify.com/CVE-2026-96292/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96292
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96292
- OSV: https://osv.dev/vulnerability/CVE-2026-96292

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96292/
Summaries are generated and may contain mistakes; the official description above is the record.
