# CVE-2026-96404: Gitea installer authentication bypass for existing accounts

> Attackers can bypass authentication and gain administrative access by submitting the installer form with an existing username when the install lock is disabled.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Oct 2026
- **Updated:** 7 Oct 2026
- **Also known as:** BIT-gitea-2026-96404, GHSA-9h7g-h754-c8x2, MINI-g7fp-pr7m-c43g, MINI-h83v-58w6-48jh

## What is CVE-2026-96404?

CVE-2026-96404 is a high-severity authentication bypass vulnerability in Gitea Gitea, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

When Gitea's web installer is reachable against a database that already contains users, such as after `INSTALL_LOCK` has been reset to `false`, submitting the install form with an administrator username matching an existing account issued an authenticated session for that account without verifying its password. If the account is an administrator, the session grants full administrative access, including changing the account's password. Databases with a single user also did not require the reinstall confirmation.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-96404?

1 open source package ship an affected version, including gitea. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitea` | Bitnami | All versions | 28.0.0 |

Products: Gitea Gitea.

## How do I fix CVE-2026-96404?

Upgrade gitea to 28.0.0 or later.

## Is CVE-2026-96404 being exploited?

There is no known exploitation of CVE-2026-96404 in the wild and no public exploit code.

## Other vulnerabilities in Gitea Gitea

- [CVE-2026-60004](https://insights.sbomify.com/CVE-2026-60004/): Gitea Code Injection (critical 9.8, exploited in the wild)
- [CVE-2026-73278](https://insights.sbomify.com/CVE-2026-73278/): Gitea WebAuthn bypass during OAuth and OIDC sign-in (critical 9.8)
- [CVE-2026-94205](https://insights.sbomify.com/CVE-2026-94205/): Gitea fork workflow approval bypass through maintainer-triggered events (critical 9.8)
- [CVE-2022-42968](https://insights.sbomify.com/CVE-2022-42968/): Gitea vulnerable to Argument Injection (critical 9.8)
- [CVE-2021-45330](https://insights.sbomify.com/CVE-2021-45330/): Improper Privilege Management in Gitea (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96404 and fix it if it is affected.

What it is: CVE-2026-96404 is a high-severity authentication bypass vulnerability in Gitea Gitea, published on 6 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-96404 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitea (Bitnami): affected all versions; fixed in 28.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96404/ (Markdown: https://insights.sbomify.com/CVE-2026-96404/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96404
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96404
- OSV: https://osv.dev/vulnerability/CVE-2026-96404

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96404/
Summaries are generated and may contain mistakes; the official description above is the record.
