# CVE-2026-9648: CVE-2026-9648

> Attackers can bypass X.509 NameConstraints to impersonate domains outside a sub-CA's permitted scope using compromised certificates.

- **Severity:** Critical 9.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 11 Jun 2026
- **Updated:** 11 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-9648, GHSA-7jx5-vvgh-vcjw, HSEC-2026-0008, UBUNTU-CVE-2026-9648, openSUSE-SU-2026:11077-1, openSUSE-SU-2026:11078-1, openSUSE-SU-2026:11079-1, openSUSE-SU-2026:11080-1, openSUSE-SU-2026:11081-1, openSUSE-SU-2026:11082-1, openSUSE-SU-2026:11083-1, openSUSE-SU-2026:11084-1, openSUSE-SU-2026:11085-1, openSUSE-SU-2026:11087-1

## What is CVE-2026-9648?

CVE-2026-9648 is a critical vulnerability in Haskell Programming Language crypton-certificate, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The crypton-x509-validation Haskell library fails to enforce X.509 NameConstraints, allowing TLS clients to accept certificates whose Subject Alternative Names fall outside the issuing CA’s permitted subtrees. This oversight enables an attacker who compromises a name-constrained sub-CA to impersonate domains beyond its intended scope.

## Which versions are affected by CVE-2026-9648?

4 open source packages ship an affected version, including crypton-x509, crypton-x509-validation and x509.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `crypton-x509` | Hackage | From 1.7.6 | 1.9.1 |
| `crypton-x509-validation` | Hackage | From 1.6.12 | 1.9.1 |
| `x509` | Hackage | From 1.4.0 | None |
| `x509-validation` | Hackage | From 1.4.0 | None |
| `ghc-aws` | openSUSE:Tumbleweed | All versions | 0.25.2-1.1 |
| `ghc-crypton-asn1-encoding` | openSUSE:Tumbleweed | All versions | 0.10.0-1.1 |
| `ghc-crypton-asn1-parse` | openSUSE:Tumbleweed | All versions | 0.10.0-1.1 |
| `ghc-crypton-asn1-types` | openSUSE:Tumbleweed | All versions | 0.4.1-1.1 |
| `ghc-crypton-pem` | openSUSE:Tumbleweed | All versions | 0.3.0-1.1 |
| `ghc-crypton-x509` | openSUSE:Tumbleweed | All versions | 1.9.1-1.1 |
| `ghc-crypton-x509-store` | openSUSE:Tumbleweed | All versions | 1.9.0-1.1 |
| `ghc-crypton-x509-system` | openSUSE:Tumbleweed | All versions | 1.9.0-1.1 |
| `ghc-crypton-x509-validation` | openSUSE:Tumbleweed | All versions | 1.9.1-1.1 |
| `git-annex` | openSUSE:Tumbleweed | All versions | 10.20260601-2.1 |

## How do I fix CVE-2026-9648?

Upgrade crypton-x509 to 1.9.1 or later.

## Is CVE-2026-9648 being exploited?

There is no known exploitation of CVE-2026-9648 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9648 and fix it if it is affected.

What it is: CVE-2026-9648 is a critical vulnerability in Haskell Programming Language crypton-certificate, published on 11 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9648 in the wild and no public exploit code.

Affected packages and fixed versions:
- crypton-x509 (Hackage): affected from 1.7.6; fixed in 1.9.1
- crypton-x509-validation (Hackage): affected from 1.6.12; fixed in 1.9.1
- x509 (Hackage): affected from 1.4.0; no fix listed
- x509-validation (Hackage): affected from 1.4.0; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9648/ (Markdown: https://insights.sbomify.com/CVE-2026-9648/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9648
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9648
- OSV: https://osv.dev/vulnerability/CVE-2026-9648

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9648/
Summaries are generated and may contain mistakes; the official description above is the record.
