# CVE-2026-96581: Authorization Bypass Through User-Controlled Key vulnerability in ash-project ash allows a user of one tenant to read, overwrite and take ov


- **Severity:** High 7.6 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 26 Oct 2026
- **Updated:** 26 Oct 2026
- **Also known as:** EEF-CVE-2026-96581, GHSA-vw7c-67pf-gh96

## What is CVE-2026-96581?

CVE-2026-96581 is a high-severity vulnerability in ash-project ash, published on 26 Oct 2026. 

### Official description

Authorization Bypass Through User-Controlled Key vulnerability in ash-project ash allows a user of one tenant to read, overwrite and take over another tenant's records via an upserting create action.

Under attribute multitenancy, Ash.Actions.Create (lib/ash/actions/create/create.ex) and Ash.Actions.Create.Bulk (lib/ash/actions/create/bulk.ex) upserted on the primary key, or on an all_tenants? identity, without scoping the conflicting record to the request's tenant. A caller of a create action with upsert? true that accepts the primary key, supplying a record id from another tenant, updated that record's upsert fields and received all of its attributes in the result. With the default upsert fields the tenant attribute was written too, moving the record into the caller's tenant. Read and update policies do not run for upserts, and tenant-scoped create policies pass because the tenant is the caller's own.

This issue affects ash: from 1.22.0 before 3.37.2.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-96581?

1 open source package ship an affected version, including ash.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `ash` | Hex | From 1.22.0 | 3.37.2 |

## How do I fix CVE-2026-96581?

Upgrade ash to 3.37.2 or later.

## Is CVE-2026-96581 being exploited?

There is no known exploitation of CVE-2026-96581 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96581 and fix it if it is affected.

What it is: CVE-2026-96581 is a high-severity vulnerability in ash-project ash, published on 26 Oct 2026. 
Exploitation: There is no known exploitation of CVE-2026-96581 in the wild and no public exploit code.

Affected packages and fixed versions:
- ash (Hex): affected from 1.22.0; fixed in 3.37.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96581/ (Markdown: https://insights.sbomify.com/CVE-2026-96581/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96581
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96581
- OSV: https://osv.dev/vulnerability/CVE-2026-96581

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96581/
Summaries are generated and may contain mistakes; the official description above is the record.
