{"answers":{"affected":"1 open source package ship an affected version, including nginx-gateway-fabric.","exploited":"There is no known exploitation of CVE-2026-96615 in the wild and no public exploit code.","fix":"Upgrade nginx-gateway-fabric to 2.8.0 or later.","what":"CVE-2026-96615 is a high-severity missing authorization vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-96615 and fix it if it is affected.\n\nWhat it is: CVE-2026-96615 is a high-severity missing authorization vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-96615 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- nginx-gateway-fabric (Bitnami): affected from 2.0.0; fixed in 2.8.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-96615/ (Markdown: https://insights.sbomify.com/CVE-2026-96615/index.md)","id":"CVE-2026-96615","markdown":"https://insights.sbomify.com/CVE-2026-96615/index.md","name":"CVE-2026-96615","record":{"aliases":["BIT-nginx-gateway-fabric-2026-96615","GHSA-h8jf-9855-344m"],"analysis":{"component_type":"cloud_service","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":true,"product_category":"NGINX Gateway Fabric","requires_auth":"low_privilege","summary":"Authenticated attackers can impersonate agents to read TLS private keys from other namespaces in NGINX Gateway Fabric deployments.","user_interaction":"not_required","vuln_class":"missing_authorization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"f5","cpe":[],"cvss":{"score":7.1,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-290","name":"Authentication Bypass by Spoofing"}],"description":"Description\nNGINX Gateway Fabric has a vulnerability when it is configured with Gateway \n\nCustom Resource Definition (CRD) and have an authenticated gRPC connection with NGINX Agent. A namespaced \n\n authenticated attacker with access to a service account may impersonate the authenticated NGINX Agent gRPC connection to read TLS private keys of Gateway deployments in another namespace. \n\nImpact\nA remote authenticated attacker may be able to read TLS private keys of Gateway deployments in another namespace. \n\nThere is no data plane exposure; this is a control plane issue only.\n\nNote: Software versions which have reached End of Technical Support (EoTS) are not evaluated.","ecosystems":["Bitnami"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"NGINX Gateway Fabric vulnerability","id":"CVE-2026-96615","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"missing_authorization","year":"2026"},"n_packages":1,"n_references":1,"next":{"headline":"Kiloview E3 NDI Encoder Insufficient Session Expiration","id":"CVE-2026-96616"},"packages":[{"ecosystem":"Bitnami","fixed":["2.8.0"],"introduced":["2.0.0"],"last_affected":[],"package":"nginx-gateway-fabric","purl":"pkg:bitnami/nginx-gateway-fabric","source":"BIT-nginx-gateway-fabric-2026-96615"}],"prev":{"headline":"Open redirect in \"ゲオアプリ\" for Android","id":"CVE-2026-96614"},"products":["NGINX Gateway Fabric"],"published":"2026-10-14","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-10-15","vendors":["F5"]},"summary":"Authenticated attackers can impersonate agents to read TLS private keys from other namespaces in NGINX Gateway Fabric deployments.","url":"https://insights.sbomify.com/CVE-2026-96615/"}