# CVE-2026-96615: NGINX Gateway Fabric vulnerability

> Authenticated attackers can impersonate agents to read TLS private keys from other namespaces in NGINX Gateway Fabric deployments.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Oct 2026
- **Updated:** 15 Oct 2026
- **Also known as:** BIT-nginx-gateway-fabric-2026-96615, GHSA-h8jf-9855-344m

## What is CVE-2026-96615?

CVE-2026-96615 is a high-severity missing authorization vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Description
NGINX Gateway Fabric has a vulnerability when it is configured with Gateway 

Custom Resource Definition (CRD) and have an authenticated gRPC connection with NGINX Agent. A namespaced 

 authenticated attacker with access to a service account may impersonate the authenticated NGINX Agent gRPC connection to read TLS private keys of Gateway deployments in another namespace. 

Impact
A remote authenticated attacker may be able to read TLS private keys of Gateway deployments in another namespace. 

There is no data plane exposure; this is a control plane issue only.

Note: Software versions which have reached End of Technical Support (EoTS) are not evaluated.

Weakness: CWE-290 (Authentication Bypass by Spoofing)

## Which versions are affected by CVE-2026-96615?

1 open source package ship an affected version, including nginx-gateway-fabric.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `nginx-gateway-fabric` | Bitnami | From 2.0.0 | 2.8.0 |

## How do I fix CVE-2026-96615?

Upgrade nginx-gateway-fabric to 2.8.0 or later.

## Is CVE-2026-96615 being exploited?

There is no known exploitation of CVE-2026-96615 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96615 and fix it if it is affected.

What it is: CVE-2026-96615 is a high-severity missing authorization vulnerability in F5 NGINX Gateway Fabric, published on 14 Oct 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-96615 in the wild and no public exploit code.

Affected packages and fixed versions:
- nginx-gateway-fabric (Bitnami): affected from 2.0.0; fixed in 2.8.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96615/ (Markdown: https://insights.sbomify.com/CVE-2026-96615/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96615
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96615
- OSV: https://osv.dev/vulnerability/CVE-2026-96615

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96615/
Summaries are generated and may contain mistakes; the official description above is the record.
