CVE-2026-9673 json-2-csv vulnerable to CSV Injection via the preventCsvInjection optio

High 7.0 Published Updated

Attackers can bypass CSV injection protections to inject malicious formulas that execute when files are opened in spreadsheet applications.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Local or same network only
Victim action needed
Not needed
Fix
Available

What is CVE-2026-9673?

CVE-2026-9673 is a high-severity vulnerability in json-2-csv, published on 28 May 2026. It can only be exploited from the same machine or local network, with no action from the victim.

Official description

Versions of the package json-2-csv from 3.15.0 and before 5.5.11 are vulnerable to CSV Injection via the preventCsvInjection option which can be bypassed. An attacker can inject formulas into CSV files, which execute when the files are opened in spreadsheet applications.

Weakness: CWE-1236

Which versions are affected by CVE-2026-9673?

2 open source packages ship an affected version, including json-2-csv.

PackageAffectedFixed in
json-2-csv npmFrom 3.15.05.5.11
json-2-csv npmFrom 3.15.05.5.11

How do I fix CVE-2026-9673?

Upgrade json-2-csv to 5.5.11 or later.

Is CVE-2026-9673 being exploited?

There is no known exploitation of CVE-2026-9673 in the wild and no public exploit code.

Sources

Also known as ECHO-b9d4-fcc8-c445, GHSA-g27c-q7cp-mhx6, MINI-8x8x-w5vf-q5pf, MINI-9v56-2vvr-8jfq, MINI-h62p-3ppm-w5cp, MINI-w2wc-qrr8-56jv.

Is CVE-2026-9673 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free