# CVE-2026-96748: Connection redirection via percent-encoded delimiter injection in connection string hosts

> Attackers can inject percent-encoded delimiters in connection strings to redirect database traffic to malicious servers, allowing observation and alteration of data.

- **Severity:** High 8.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 24 Sep 2026
- **Updated:** 24 Sep 2026
- **Also known as:** AZL-105107, DEBIAN-CVE-2026-96748, ECHO-130e-9a6b-8aff, GHSA-vp6j-j7w5-5xjj, MINI-gqc7-xmpr-w538, PYSEC-2026-4297, ROOT-APP-PYPI-CVE-2026-96748, UBUNTU-CVE-2026-96748

## What is CVE-2026-96748?

CVE-2026-96748 is a high-severity server-side request forgery vulnerability in MongoDB Python Driver, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

PyMongo's connection string parsing decodes percent-encoded characters in the host portion before the host list is separated on its delimiters. When an application places a hostname value supplied by an unauthenticated party into a connection string, that party may cause additional servers of their choosing to be added to the application's database client. The application may then send its authentication exchange and database operations to one of those servers, which can observe limited information and return altered results.

Weakness: CWE-177 (Improper Handling of URL Encoding (Hex Encoding))

## Which versions are affected by CVE-2026-96748?

3 open source packages ship an affected version, including pymongo.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pymongo` | PyPI | From 3.5.0 | 4.18.2 |
| `pymongo` | PyPI | From 3.5.0 | 4.18.2 |
| `pymongo` | PyPI | From 3.5.0 | 4.18.2 |

## How do I fix CVE-2026-96748?

Upgrade pymongo to 4.18.2 or later.

## Is CVE-2026-96748 being exploited?

There is no known exploitation of CVE-2026-96748 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96748 and fix it if it is affected.

What it is: CVE-2026-96748 is a high-severity server-side request forgery vulnerability in MongoDB Python Driver, published on 24 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-96748 in the wild and no public exploit code.

Affected packages and fixed versions:
- pymongo (PyPI): affected from 3.5.0; fixed in 4.18.2
- pymongo (PyPI): affected from 3.5.0; fixed in 4.18.2
- pymongo (PyPI): affected from 3.5.0; fixed in 4.18.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96748/ (Markdown: https://insights.sbomify.com/CVE-2026-96748/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96748
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96748
- OSV: https://osv.dev/vulnerability/CVE-2026-96748

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96748/
Summaries are generated and may contain mistakes; the official description above is the record.
