CVE-2026-9675 undici WebSocket client vulnerable to denial of service via cumulative fragment bypass
A malicious WebSocket server can cause memory exhaustion and denial of service in applications using the undici WebSocket client by bypassing cumulative payload size limits.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-9675?
CVE-2026-9675 is a high-severity denial of service vulnerability in Nodejs Undici, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Impact: The undici WebSocket client enforces maxPayloadSize per-frame but does not enforce the cumulative size of fragmented uncompressed messages. A malicious WebSocket server can stream many small fragments that each pass per-frame validation but collectively exceed the configured limit, causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service.
Affected applications are those using the undici WebSocket client (new WebSocket(...)) that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint.
This is a regression specific to undici 8.1.0. The 6.25.0 line shipped the equivalent cumulative check from the start and is unaffected. The 7.x line never had the maxPayloadSize feature and is also unaffected.
Patches: Upgrade to undici >= 8.5.0.
Workarounds: No workaround is available. The fix must be applied through an upgrade.
Which versions are affected by CVE-2026-9675?
2 open source packages ship an affected version, including undici. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
undici npm | From 8.0.0 | 8.5.0 |
undici npm | From 8.0.0 | 8.5.0 |
Linux distribution packages (8)
nodejs24 Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-bin Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-devel Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-docs Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-full-i18n Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-libs Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
nodejs24-npm Red Hat:hummingbird:1 | All versions | 0:11.13.0-1.24.16.0.1.hum1 |
nodejs24-npm-bin Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
Products include Nodejs Undici.
How do I fix CVE-2026-9675?
Upgrade undici to 8.5.0 or later.
Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.
Is CVE-2026-9675 being exploited?
There is no known exploitation of CVE-2026-9675 in the wild and no public exploit code.
Other vulnerabilities in Nodejs Undici
- CVE-2026-109855 undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake
- CVE-2026-109869 undici vulnerable to Denial of Service via unhandled error on excessive content-encodings
- CVE-2026-87018 undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation
- CVE-2026-19534 undici vulnerable to Denial of Service via unrequested WebSocket subprotocol
- CVE-2026-12151 undici WebSocket client vulnerable to denial of service via fragment count bypass
Sources
Also known as GHSA-38rv-x7px-6hhq, MINI-p7q9-9ff7-5xg9, RHSA-2026:25561, ROOT-APP-NPM-CVE-2026-9675, UBUNTU-CVE-2026-9675.