# CVE-2026-9675: undici WebSocket client vulnerable to denial of service via cumulative fragment bypass

> A malicious WebSocket server can cause memory exhaustion and denial of service in applications using the undici WebSocket client by bypassing cumulative payload size limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 17 Jun 2026
- **Updated:** 17 Jun 2026
- **Also known as:** GHSA-38rv-x7px-6hhq, MINI-p7q9-9ff7-5xg9, RHSA-2026:25561, ROOT-APP-NPM-CVE-2026-9675, UBUNTU-CVE-2026-9675

## What is CVE-2026-9675?

CVE-2026-9675 is a high-severity denial of service vulnerability in Nodejs Undici, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Impact:
The undici WebSocket client enforces maxPayloadSize per-frame but does not enforce the cumulative size of fragmented uncompressed messages. A malicious WebSocket server can stream many small fragments that each pass per-frame validation but collectively exceed the configured limit, causing unbounded memory growth in the client process. The result is memory exhaustion and a denial of service.

Affected applications are those using the undici WebSocket client (new WebSocket(...)) that can be induced to connect to an attacker-controlled or compromised WebSocket endpoint.

This is a regression specific to undici 8.1.0. The 6.25.0 line shipped the equivalent cumulative check from the start and is unaffected. The 7.x line never had the maxPayloadSize feature and is also unaffected.

Patches:
Upgrade to undici >= 8.5.0.

Workarounds:
No workaround is available. The fix must be applied through an upgrade.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-9675?

2 open source packages ship an affected version, including undici. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `undici` | npm | From 8.0.0 | 8.5.0 |
| `undici` | npm | From 8.0.0 | 8.5.0 |
| `nodejs24` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-bin` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-devel` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-docs` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-full-i18n` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-libs` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |
| `nodejs24-npm` | Red Hat:hummingbird:1 | All versions | 0:11.13.0-1.24.16.0.1.hum1 |
| `nodejs24-npm-bin` | Red Hat:hummingbird:1 | All versions | 0:24.16.0-1.hum1 |

Products: Nodejs Undici.

## How do I fix CVE-2026-9675?

Upgrade undici to 8.5.0 or later.

## Is CVE-2026-9675 being exploited?

There is no known exploitation of CVE-2026-9675 in the wild and no public exploit code.

## Other vulnerabilities in Nodejs Undici

- [CVE-2026-109855](https://insights.sbomify.com/CVE-2026-109855/): undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake (high 7.5)
- [CVE-2026-109869](https://insights.sbomify.com/CVE-2026-109869/): undici vulnerable to Denial of Service via unhandled error on excessive content-encodings (high 7.5)
- [CVE-2026-87018](https://insights.sbomify.com/CVE-2026-87018/): undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation (high 7.5)
- [CVE-2026-19534](https://insights.sbomify.com/CVE-2026-19534/): undici vulnerable to Denial of Service via unrequested WebSocket subprotocol (high 7.5)
- [CVE-2026-12151](https://insights.sbomify.com/CVE-2026-12151/): undici WebSocket client vulnerable to denial of service via fragment count bypass (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9675 and fix it if it is affected.

What it is: CVE-2026-9675 is a high-severity denial of service vulnerability in Nodejs Undici, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9675 in the wild and no public exploit code.

Affected packages and fixed versions:
- undici (npm): affected from 8.0.0; fixed in 8.5.0
- undici (npm): affected from 8.0.0; fixed in 8.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9675/ (Markdown: https://insights.sbomify.com/CVE-2026-9675/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9675
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9675
- OSV: https://osv.dev/vulnerability/CVE-2026-9675

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9675/
Summaries are generated and may contain mistakes; the official description above is the record.
