# CVE-2026-96760: Authlib library contains a signature‑verification bypass vulnerability

> Attackers can bypass signature verification in Authlib, accepting unsigned JWTs as valid, leading to potential authentication or authorization bypasses.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Sep 2026
- **Updated:** 1 Oct 2026
- **Also known as:** DEBIAN-CVE-2026-96760, ECHO-c5ba-7fd7-ab22, GHSA-6v38-4h7w-rj9h, MINI-p48w-7ffj-27j5, UBUNTU-CVE-2026-96760

## What is CVE-2026-96760?

CVE-2026-96760 is a critical vulnerability in Authlib, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Authlib (v1.7.2 and below) contains a signature verification bypass vulnerability. The JsonWebSignature.deserialize_json() method accepts a JSON Serialization JWS object and returns the payload as successfully verified without checking for a signature and without requiring a cryptographic key.

Weakness: CWE-670 (Always-Incorrect Control Flow Implementation), CWE-358 (Improperly Implemented Security Check for Standard), CWE-347 (Improper Verification of Cryptographic Signature), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-96760?

2 open source packages ship an affected version, including authlib.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `authlib` | PyPI | All versions | 1.9.0 |
| `authlib` | PyPI | All versions | 1.9.0 |

## How do I fix CVE-2026-96760?

Upgrade authlib to 1.9.0 or later.

## Is CVE-2026-96760 being exploited?

There is no known exploitation of CVE-2026-96760 in the wild and no public exploit code.

Public exploit code:

- Authlib 1.7.2: Signature Verification Bypass - General JSON JWS Accepts Unsigned Payload when `signatures` is Empty (github_poc): https://github.com/uziii2208/CVE-2026-96760

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96760 and fix it if it is affected.

What it is: CVE-2026-96760 is a critical vulnerability in Authlib, published on 28 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-96760 in the wild and no public exploit code.

Affected packages and fixed versions:
- authlib (PyPI): affected all versions; fixed in 1.9.0
- authlib (PyPI): affected all versions; fixed in 1.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96760/ (Markdown: https://insights.sbomify.com/CVE-2026-96760/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96760
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96760
- OSV: https://osv.dev/vulnerability/CVE-2026-96760

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96760/
Summaries are generated and may contain mistakes; the official description above is the record.
