# CVE-2026-96806: Auth bypass in Apache Airflow Keycloak provider

> Attackers on shared workstations can maintain access after logout because the Keycloak auth manager issues a new valid token, requiring an upgrade to the provider.

- **Severity:** Medium 5.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 16 Oct 2026
- **Also known as:** GHSA-2vv4-mgc4-grm2

## What is CVE-2026-96806?

CVE-2026-96806 is a medium-severity authentication bypass vulnerability in Apache Airflow Keycloak provider, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

The Apache Airflow Keycloak auth manager did not end the session on logout: the logout route revoked the presented token, but `KeycloakJWTMiddleware` then issued a new, unrevoked token on the same response, so the user stayed logged in. Deployments using the Keycloak auth manager are affected: after a user logs out, anyone with later access to the same browser (for example on a shared workstation) can continue to act as that user.

Users of apache-airflow-providers-keycloak are recommended to upgrade to apache-airflow-providers-keycloak 0.11.1 or later.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-96806?


## How do I fix CVE-2026-96806?

No fix has been published for CVE-2026-96806 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-96806 being exploited?

There is no known exploitation of CVE-2026-96806 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96806 and fix it if it is affected.

What it is: CVE-2026-96806 is a medium-severity authentication bypass vulnerability in Apache Airflow Keycloak provider, published on 15 Oct 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-96806 in the wild and no public exploit code.

Affected product: Apache Airflow Keycloak provider. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96806/ (Markdown: https://insights.sbomify.com/CVE-2026-96806/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96806
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96806
- OSV: https://osv.dev/vulnerability/CVE-2026-96806

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96806/
Summaries are generated and may contain mistakes; the official description above is the record.
