CVE-2026-96883 Type confusion in AWS pgcollection allows remote code execution

High 8.7 Published Updated

An authenticated remote user can execute arbitrary code as the postgres user via crafted SQL statements exploiting a type confusion vulnerability in the pgcollection extension.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-96883?

CVE-2026-96883 is a high-severity memory corruption vulnerability in AWS pgcollection, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

Official description

pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.

To remediate this issue, users should upgrade to version 2.1.2 or later.

Weakness: CWE-843

Which versions are affected by CVE-2026-96883?

How do I fix CVE-2026-96883?

No fix has been published for CVE-2026-96883 yet. Limit exposure of the affected software until one is available.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-96883 being exploited?

There is no known exploitation of CVE-2026-96883 in the wild and no public exploit code.

Sources

Also known as GHSA-g539-cj32-hv6r, UBUNTU-CVE-2026-96883.

Is CVE-2026-96883 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free