{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-96883 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2026-96883 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-96883 is a high-severity memory corruption vulnerability in AWS pgcollection, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-96883 and fix it if it is affected.\n\nWhat it is: CVE-2026-96883 is a high-severity memory corruption vulnerability in AWS pgcollection, published on 24 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-96883 in the wild and no public exploit code.\n\nAffected product: AWS pgcollection. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-96883/ (Markdown: https://insights.sbomify.com/CVE-2026-96883/index.md)","id":"CVE-2026-96883","markdown":"https://insights.sbomify.com/CVE-2026-96883/index.md","name":"CVE-2026-96883","record":{"aliases":["GHSA-g539-cj32-hv6r","UBUNTU-CVE-2026-96883"],"analysis":{"component_type":"database","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"PostgreSQL extension","requires_auth":"low_privilege","summary":"An authenticated remote user can execute arbitrary code as the postgres user via crafted SQL statements exploiting a type confusion vulnerability in the pgcollection extension.","user_interaction":"not_required","vuln_class":"memory_corruption"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"AMZN","cpe":[],"cvss":{"score":8.7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-843","name":"Access of Resource Using Incompatible Type"}],"description":"pgcollection is an open source extension to PostgreSQL. A type confusion issue in AWS pgcollection 2.0.0 through 2.1.1 might allow an authenticated remote user to execute arbitrary code as the postgres operating system user via crafted SQL statements that rely on mismatched type metadata in collection value retrieval and array conversion functions.\n\nTo remediate this issue, users should upgrade to version 2.1.2 or later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Type confusion in AWS pgcollection allows remote code execution","id":"CVE-2026-96883","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"memory_corruption","year":"2026"},"n_packages":0,"n_references":3,"next":{"headline":"MantisZip Preview MainWindow.UI.cs Path.Combine path traversal","id":"CVE-2026-96884"},"packages":[],"prev":{"headline":"TaleLin lin-cms-spring-boot book Endpoint BookController.java searchBook improper authorization","id":"CVE-2026-96882"},"products":["pgcollection"],"published":"2026-09-24","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-24","vendors":["AWS"]},"summary":"An authenticated remote user can execute arbitrary code as the postgres user via crafted SQL statements exploiting a type confusion vulnerability in the pgcollection extension.","url":"https://insights.sbomify.com/CVE-2026-96883/"}