# CVE-2026-96893: Improper Neutralization of Input Used for LLM Prompting in GitLab

> Authenticated users can inject content into AI agent instructions to execute unintended commands attributed to other users.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 13 Oct 2026
- **Updated:** 14 Oct 2026
- **Also known as:** BIT-gitlab-2026-96893, GHSA-5vgp-j37h-7wfx, MINI-c88m-cpq9-w6m9, MINI-f3f8-2w5x-fqpc, MINI-xjpf-g8c7-fpp5, UBUNTU-CVE-2026-96893

## What is CVE-2026-96893?

CVE-2026-96893 is a high-severity code injection vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

GitLab has remediated an issue in GitLab EE affecting all versions from 19.1 before 19.2.8, 19.3 before 19.3.5, and 19.4 before 19.4.2 that, under certain conditions, could have allowed an authenticated user to inject specially crafted content into AI agent instructions, potentially causing unintended command execution attributed to other users, due to improper neutralization of special elements in AI conversation context construction.

Weakness: CWE-74 (Improper Neutralization of Special Elements in Output Used by a Downstream Component), CWE-1427 (Improper Neutralization of Input Used for LLM Prompting)

## Which versions are affected by CVE-2026-96893?

1 open source package ship an affected version, including gitlab. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `gitlab` | Bitnami | From 19.1.0 | 19.2.8, 19.3.5, 19.4.2 |

Products: Gitlab Gitlab.

## How do I fix CVE-2026-96893?

Upgrade gitlab to a fixed version for your release line: 19.2.8, 19.3.5 or 19.4.2.

## Is CVE-2026-96893 being exploited?

There is no known exploitation of CVE-2026-96893 in the wild and no public exploit code.

## Other vulnerabilities in Gitlab Gitlab

- [CVE-2026-97229](https://insights.sbomify.com/CVE-2026-97229/): GitLab Community Edition and Enterprise Edition Integer Overflow or Wraparound (critical 10.0, exploited in the wild)
- [CVE-2026-85706](https://insights.sbomify.com/CVE-2026-85706/): GitLab Community Edition and Enterprise Edition Path Traversal (critical 10.0, exploited in the wild)
- [CVE-2023-7028](https://insights.sbomify.com/CVE-2023-7028/): GitLab Community and Enterprise Editions Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2021-22205](https://insights.sbomify.com/CVE-2021-22205/): GitLab Community and Enterprise Editions Remote Code Execution (critical 10.0, exploited in the wild)
- [CVE-2021-39935](https://insights.sbomify.com/CVE-2021-39935/): GitLab Community and Enterprise Editions Server-Side Request Forgery (SSRF) (medium 6.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-96893 and fix it if it is affected.

What it is: CVE-2026-96893 is a high-severity code injection vulnerability in Gitlab Gitlab, published on 13 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-96893 in the wild and no public exploit code.

Affected packages and fixed versions:
- gitlab (Bitnami): affected from 19.1.0; fixed in 19.2.8, 19.3.5, 19.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-96893/ (Markdown: https://insights.sbomify.com/CVE-2026-96893/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-96893
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-96893
- OSV: https://osv.dev/vulnerability/CVE-2026-96893

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-96893/
Summaries are generated and may contain mistakes; the official description above is the record.
