{"answers":{"affected":"4 open source packages ship an affected version, including undici. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-9697 in the wild and no public exploit code.","fix":"Upgrade undici to a fixed version for your release line: 7.28.0 or 8.5.0.","what":"CVE-2026-9697 is a high-severity vulnerability in Nodejs Undici, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-9697 and fix it if it is affected.\n\nWhat it is: CVE-2026-9697 is a high-severity vulnerability in Nodejs Undici, published on 17 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-9697 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- undici (npm): affected from 7.23.0; fixed in 7.28.0\n- undici (npm): affected from 7.23.0; fixed in 7.28.0\n- undici (npm): affected from 8.0.0; fixed in 8.5.0\n- undici (npm): affected from 8.0.0; fixed in 8.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-9697/ (Markdown: https://insights.sbomify.com/CVE-2026-9697/index.md)","id":"CVE-2026-9697","markdown":"https://insights.sbomify.com/CVE-2026-9697/index.md","name":"CVE-2026-9697","record":{"aliases":["AZL-91227","DEBIAN-CVE-2026-9697","ECHO-b305-6c79-97eb","GHSA-vmh5-mc38-953g","MINI-7cj7-6cr6-r892","MINI-8xv9-p578-x7w8","MINI-hjf3-g87w-8h5m","MINI-mfq8-82wj-mc3p","MINI-mhv3-j6xq-cvrw","MINI-mxg4-m3w5-w6qw","ROOT-APP-NPM-CVE-2026-9697","UBUNTU-CVE-2026-9697"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","data_modify"],"network_reachable":"yes","non_default_config":true,"product_category":"Node.js HTTP client","requires_auth":"none","summary":"Attackers can perform man-in-the-middle attacks on HTTPS traffic routed through SOCKS5 proxies by bypassing custom TLS certificate validation settings in undici.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"openjs","cpe":[{"product":"undici","vendor":"nodejs"}],"cvss":{"score":7.4,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"Impact:\nundici's ProxyAgent silently drops the requestTls option when configured with a SOCKS5 proxy URI (socks5:// or socks://). The target HTTPS connection through the SOCKS5 tunnel falls back to Node's default trust store, ignoring user-configured ca, cert, key, rejectUnauthorized, and servername settings.\n\nApplications that pin to an internal or corporate CA via requestTls.ca will, when their proxy URI is SOCKS5, get the default Mozilla CA bundle as the trust anchor instead. Any cert signed by any publicly-trusted CA for the target hostname is accepted, breaking the intended pin and enabling MITM read and tamper of the HTTPS exchange.\n\nAffected applications are those that use undici's ProxyAgent (or Socks5ProxyAgent directly) with SOCKS5 AND rely on requestTls for TLS scope restriction. The bug was introduced in undici 7.23.0 when SOCKS5 support was added.\n\nPatches:\nUpgrade to undici v7.28.0 or v8.5.0.\n\nWorkarounds:\nNo workaround is available within the SOCKS5 path. If a SOCKS5 proxy with TLS scope restriction is required and an upgrade is not yet possible, route the traffic through an HTTP-proxy ProxyAgent instead, where requestTls is honored correctly.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"undici vulnerable to TLS certificate validation bypass via dropped requestTls in SOCKS5 ProxyAgent","id":"CVE-2026-9697","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":"nodejs:undici","products":["nodejs:undici"],"type":"security_feature_bypass","year":"2026"},"n_packages":4,"n_references":2,"next":{"headline":"DBI versions before 1.648 for Perl saved errors in a limited-sized buffer","id":"CVE-2026-9698"},"packages":[{"ecosystem":"npm","fixed":["7.28.0"],"introduced":["7.23.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-vmh5-mc38-953g"},{"ecosystem":"npm","fixed":["7.28.0"],"introduced":["7.23.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-vmh5-mc38-953g"},{"ecosystem":"npm","fixed":["8.5.0"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":null,"source":"GHSA-vmh5-mc38-953g"},{"ecosystem":"npm","fixed":["8.5.0"],"introduced":["8.0.0"],"last_affected":[],"package":"undici","purl":"pkg:npm/undici","source":"GHSA-vmh5-mc38-953g"}],"prev":{"headline":"Download Manager \u003c= 3.3.58 - Authenticated (Contributor+) Stored Cross-Site Scripting via wpdm_packages Shortcode","id":"CVE-2026-9696"},"products":["undici"],"published":"2026-06-17","related":[{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to Denial of Service via failed HTTP/2 handshake","id":"CVE-2026-109855","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unhandled error on excessive content-encodings","id":"CVE-2026-109869","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via TLS 1.2 certificate-changing renegotiation","id":"CVE-2026-87018","kev_date_added":null,"published":"2026-10-15"},{"cvss_score":7.5,"headline":"undici vulnerable to Denial of Service via unrequested WebSocket subprotocol","id":"CVE-2026-19534","kev_date_added":null,"published":"2026-09-04"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via fragment count bypass","id":"CVE-2026-12151","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici vulnerable to cross-origin request routing via SOCKS5 proxy pool reuse","id":"CVE-2026-6734","kev_date_added":null,"published":"2026-06-17"},{"cvss_score":7.5,"headline":"undici WebSocket client vulnerable to denial of service via cumulative fragment bypass","id":"CVE-2026-9675","kev_date_added":null,"published":"2026-06-17"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-10","vendors":["undici"]},"summary":"Attackers can perform man-in-the-middle attacks on HTTPS traffic routed through SOCKS5 proxies by bypassing custom TLS certificate validation settings in undici.","url":"https://insights.sbomify.com/CVE-2026-9697/"}