# CVE-2026-9704: Keycloak: keycloak: privilege escalation due to oversized subject_token jwt

> Low-privilege users can escalate privileges by sending oversized JWTs that trigger a fallback to client credentials in Keycloak.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 26 Jun 2026
- **Also known as:** ECHO-1969-c688-a45c, GHSA-rr5q-3xwr-f323, MINI-fp25-7wqp-crch, MINI-gq94-v5qx-vxp4

## What is CVE-2026-9704?

CVE-2026-9704 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak. An authenticated user with low privileges can exploit this vulnerability by sending an oversized subject_token JSON Web Token (JWT) to the TokenEndpoint. When the token exceeds a 4000-character limit, it is silently dropped, causing the system to fall back to client credentials. This allows the user to gain the permissions of the client's service account, leading to privilege escalation.

Weakness: CWE-1284 (Improper Validation of Specified Quantity in Input)

## Which versions are affected by CVE-2026-9704?

4 open source packages ship an affected version, including org.keycloak:keycloak-server-spi-private and org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 26.6.3 |
| `org.keycloak:keycloak-server-spi-private` | Maven | All versions | 26.6.3 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.3 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.3 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9704?

Upgrade org.keycloak:keycloak-server-spi-private to 26.6.3 or later.

## Is CVE-2026-9704 being exploited?

There is no known exploitation of CVE-2026-9704 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9704 and fix it if it is affected.

What it is: CVE-2026-9704 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9704 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 26.6.3
- org.keycloak:keycloak-server-spi-private (Maven): affected all versions; fixed in 26.6.3
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.3
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9704/ (Markdown: https://insights.sbomify.com/CVE-2026-9704/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9704
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9704
- OSV: https://osv.dev/vulnerability/CVE-2026-9704

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9704/
Summaries are generated and may contain mistakes; the official description above is the record.
