# CVE-2026-9705: Keycloak: keycloak: attacker can re-enable and take over disabled clients via registration access token

> Attackers with a registration token can re-enable disabled clients and reset secrets, bypassing administrative controls to regain API access.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 29 Jun 2026
- **Also known as:** BIT-keycloak-2026-9705, GHSA-r7rc-c989-86g6

## What is CVE-2026-9705?

CVE-2026-9705 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak's client registration service. A remote attacker, possessing a previously issued Registration Access Token (RAT), could exploit this vulnerability to re-enable a client that an administrator had explicitly disabled. This bypasses security controls, allowing the attacker to reset the client's secret and potentially regain privileged API access. The primary impact includes unauthorized information disclosure and potential integrity compromise.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-9705?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.13, 26.6.4 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9705?

Upgrade org.keycloak:keycloak-services to 26.6.4 or later.

## Is CVE-2026-9705 being exploited?

There is no known exploitation of CVE-2026-9705 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9705 and fix it if it is affected.

What it is: CVE-2026-9705 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9705 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.13, 26.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9705/ (Markdown: https://insights.sbomify.com/CVE-2026-9705/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9705
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9705
- OSV: https://osv.dev/vulnerability/CVE-2026-9705

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9705/
Summaries are generated and may contain mistakes; the official description above is the record.
