# CVE-2026-9712: Insecure direct object reference

> Attackers with valid UUIDs can access unauthorized export files due to missing ownership verification in the pretix API.

- **Severity:** Low 3.8 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:H/SI:N/SA:N/E:U`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-72p9-6vv6-gvqh, PYSEC-2026-2960

## What is CVE-2026-9712?

CVE-2026-9712 is a low-severity vulnerability in pretix, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

When creating an export through the pretix API, API clients are 
returned an UUID value for their export job (a long, random string like 
35742818-c375-4d15-839f-d49aecce94d6). Using this UUID, the API client 
can then request the actual file for download. The same kind of UUID is 
used in other places in pretix when temporary files are generated for 
internal use or download.

One remaining API endpoint, however, wrongfully did not verify if the
 UUID used for download actually belongs to a file that is supposed to 
be downloadable and belongs to the correct user. In reality, this is 
hard to exploit because an attacker would need to have access to a valid
 UUID for the file they desire which is unlikely to happen without a 
separate security problem giving them access to logs etc.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-9712?

3 open source packages ship an affected version, including pretix.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pretix` | PyPI | All versions | 2026.4.2 |
| `pretix` | PyPI | All versions | 2026.4.2 |
| `pretix` | PyPI | All versions | 2026.4.2 |

## How do I fix CVE-2026-9712?

Upgrade pretix to 2026.4.2 or later.

## Is CVE-2026-9712 being exploited?

There is no known exploitation of CVE-2026-9712 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9712 and fix it if it is affected.

What it is: CVE-2026-9712 is a low-severity vulnerability in pretix, published on 27 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9712 in the wild and no public exploit code.

Affected packages and fixed versions:
- pretix (PyPI): affected all versions; fixed in 2026.4.2
- pretix (PyPI): affected all versions; fixed in 2026.4.2
- pretix (PyPI): affected all versions; fixed in 2026.4.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9712/ (Markdown: https://insights.sbomify.com/CVE-2026-9712/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9712
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9712
- OSV: https://osv.dev/vulnerability/CVE-2026-9712

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9712/
Summaries are generated and may contain mistakes; the official description above is the record.
