# CVE-2026-97335: Incorrect authorization in LXD storage volume API allows reading volumes from other projects

> Authenticated users can read storage volumes from other projects by omitting the source type in API requests, exposing sensitive data.

- **Severity:** High 7.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 28 Sep 2026
- **Updated:** 28 Sep 2026
- **Also known as:** DEBIAN-CVE-2026-97335, GHSA-p456-92fx-44xh, UBUNTU-CVE-2026-97335

## What is CVE-2026-97335?

CVE-2026-97335 is a high-severity missing authorization vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Incorrect authorization in the custom storage volume creation endpoint in Canonical LXD versions 5.0.0 and later (fixed in 5.0.10, 5.21.8 and 6.10) on Linux allows an authenticated client with permission to create custom volumes in a project to copy, and so read, any custom storage volume from any other project on the server, including its snapshots and configuration. The client does this with a crafted request that sets a source volume and source.project but omits source.type.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-97335?


## How do I fix CVE-2026-97335?

No fix has been published for CVE-2026-97335 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-97335 being exploited?

There is no known exploitation of CVE-2026-97335 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-97335 and fix it if it is affected.

What it is: CVE-2026-97335 is a high-severity missing authorization vulnerability in Canonical LXD, published on 28 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-97335 in the wild and no public exploit code.

Affected product: Canonical LXD. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-97335/ (Markdown: https://insights.sbomify.com/CVE-2026-97335/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-97335
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-97335
- OSV: https://osv.dev/vulnerability/CVE-2026-97335

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-97335/
Summaries are generated and may contain mistakes; the official description above is the record.
