# CVE-2026-9739: MCP Toolbox for Databases vulnerable to DNS rebinding attacks

> Attackers can bypass origin restrictions via DNS rebinding due to a hardcoded wildcard CORS header in the SSE handler.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 May 2026
- **Updated:** 28 May 2026
- **Also known as:** GHSA-7pf3-8xx7-rvhf, GO-2026-5870

## What is CVE-2026-9739?

CVE-2026-9739 is a critical vulnerability in Google MCP Toolbox for Databases, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Vulnerable to DNS rebinding attacks when using SSE (http://b/499408790). During the beta phase, we implemented `allowed-origins` and `allowed-hosts` flags to align with MCP security guidelines. However, the hardcoded `Access-Control-Allow-Origin: *` header in the SSE initialization handler was inadvertently retained. This vulnerability specifically impacts users connecting via Toolbox using SSE under specification v2024-11-05.

Weakness: CWE-942 (Permissive Cross-domain Security Policy with Untrusted Domains)

## Which versions are affected by CVE-2026-9739?

3 open source packages ship an affected version, including github.com/googleapis/mcp-toolbox.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.2.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.2.0 |
| `github.com/googleapis/mcp-toolbox` | Go | All versions | 1.2.0 |

## How do I fix CVE-2026-9739?

Upgrade github.com/googleapis/mcp-toolbox to 1.2.0 or later.

## Is CVE-2026-9739 being exploited?

There is no known exploitation of CVE-2026-9739 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9739 and fix it if it is affected.

What it is: CVE-2026-9739 is a critical vulnerability in Google MCP Toolbox for Databases, published on 27 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-9739 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.2.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.2.0
- github.com/googleapis/mcp-toolbox (Go): affected all versions; fixed in 1.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9739/ (Markdown: https://insights.sbomify.com/CVE-2026-9739/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9739
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9739
- OSV: https://osv.dev/vulnerability/CVE-2026-9739

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9739/
Summaries are generated and may contain mistakes; the official description above is the record.
