# CVE-2026-97469: PostgreSQL Anonymizer: RESTRICTED functions are reachable through a subLink

> Unprivileged users can bypass restrictions to call protected functions and deduce salt values via brute-force attacks in PostgreSQL Anonymizer.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 25 Sep 2026
- **Also known as:** GHSA-g8c9-3556-8wq9

## What is CVE-2026-97469?

CVE-2026-97469 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PostgreSQL Anonymizer contains a vulnerability that allows unprivileged masked users to repeatedly call the anon.hash() function and collects (seed, hash_output) pairs to perform an offline brute-force attack and deduce the salt. A masked role can run a RESTRICTED function when the call is placed inside the sub-select. The problem is resolved in PostgreSQL Anonymizer 3.2.3 and later versions

Weakness: CWE-328 (Use of Weak Hash)

## Which versions are affected by CVE-2026-97469?


## How do I fix CVE-2026-97469?

No fix has been published for CVE-2026-97469 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-97469 being exploited?

There is no known exploitation of CVE-2026-97469 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-97469 and fix it if it is affected.

What it is: CVE-2026-97469 is a medium-severity vulnerability in DALIBO PostgreSQL Anonymizer, published on 25 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-97469 in the wild and no public exploit code.

Affected product: DALIBO PostgreSQL Anonymizer. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-97469/ (Markdown: https://insights.sbomify.com/CVE-2026-97469/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-97469
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-97469
- OSV: https://osv.dev/vulnerability/CVE-2026-97469

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-97469/
Summaries are generated and may contain mistakes; the official description above is the record.
