CVE-2026-97869 langchain4j LangChain4j-agentic AgenticScopeJsonSerializationIT.java AgenticScopeSerializer.fromJson deserialization

Low 2.1 Published Updated

Remote attackers can execute arbitrary code via unsafe deserialization in LangChain4j if AgenticScope persistence is enabled and the store is writable.

Exploited in the wild
Not known
Login needed
An administrator
Attackable
Over the internet
Victim action needed
Not needed
Fix
None listed

What is CVE-2026-97869?

CVE-2026-97869 is a low-severity unsafe deserialization vulnerability in langchain4j, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.

Official description

A flaw has been found in langchain4j up to 1.5.3-beta10/1.11.10-beta18/1.18.1-beta27. This vulnerability affects the function AgenticScopeSerializer.fromJson of the file AgenticScopeJsonSerializationIT.java of the component LangChain4j-agentic. This manipulation causes deserialization. Remote exploitation of the attack is possible. The attack's complexity is rated as high. It is stated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 1.5.3-beta11, 1.11.10-beta19 and 1.18.1-beta28 is able to resolve this issue. Upgrading the affected component is advised. The project maintainer kindly explains: "The issue was reported to us privately on 23 July 2026 and fixed in releases published on 29 July 2026. It is tracked as GHSA-gmwr-7wmf-mrjm. Exploitation requires an application to have enabled AgenticScope persistence, which is opt-in, and an attacker who can already write to that store. All maintained release lines have been patched."

Weakness: CWE-502, CWE-20

Which versions are affected by CVE-2026-97869?

How do I fix CVE-2026-97869?

No fix has been published for CVE-2026-97869 yet. Limit exposure of the affected software until one is available.

Upgrade, and only deserialise data from trusted sources or with an allow-list of types. More about Unsafe deserialization.

Is CVE-2026-97869 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-97869 exists.

Sources

Also known as GHSA-gmwr-7wmf-mrjm, GHSA-hg7f-vffm-ppc6.

Is CVE-2026-97869 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free