{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-97869 exists.","fix":"No fix has been published for CVE-2026-97869 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-97869 is a low-severity unsafe deserialization vulnerability in langchain4j, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-97869 and fix it if it is affected.\n\nWhat it is: CVE-2026-97869 is a low-severity unsafe deserialization vulnerability in langchain4j, published on 25 Sep 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-97869 exists.\n\nAffected product: langchain4j. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-97869/ (Markdown: https://insights.sbomify.com/CVE-2026-97869/index.md)","id":"CVE-2026-97869","markdown":"https://insights.sbomify.com/CVE-2026-97869/index.md","name":"CVE-2026-97869","record":{"aliases":["GHSA-gmwr-7wmf-mrjm","GHSA-hg7f-vffm-ppc6"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":true,"product_category":"Java AI library","requires_auth":"high_privilege","summary":"Remote attackers can execute arbitrary code via unsafe deserialization in LangChain4j if AgenticScope persistence is enabled and the store is writable.","user_interaction":"not_required","vuln_class":"deserialization"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulDB","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:H/AT:N/PR:H/UI:N/VC:L/VI:L/VA:L/SC:N/SI:N/SA:N/E:P","version":"4.0"},"cwes":[{"id":"CWE-502","name":"Deserialization of Untrusted Data"},{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A flaw has been found in langchain4j up to 1.5.3-beta10/1.11.10-beta18/1.18.1-beta27. This vulnerability affects the function AgenticScopeSerializer.fromJson of the file AgenticScopeJsonSerializationIT.java of the component LangChain4j-agentic. This manipulation causes deserialization. Remote exploitation of the attack is possible. The attack's complexity is rated as high. It is stated that the exploitability is difficult. The exploit has been published and may be used. Upgrading to version 1.5.3-beta11, 1.11.10-beta19 and 1.18.1-beta28 is able to resolve this issue. Upgrading the affected component is advised. The project maintainer kindly explains: \"The issue was reported to us privately on 23 July 2026 and fixed in releases published on 29 July 2026. It is tracked as GHSA-gmwr-7wmf-mrjm. Exploitation requires an application to have enabled AgenticScope persistence, which is opt-in, and an attacker who can already write to that store. All maintained release lines have been patched.\"","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"langchain4j LangChain4j-agentic AgenticScopeJsonSerializationIT.java AgenticScopeSerializer.fromJson deserialization","id":"CVE-2026-97869","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"deserialization","year":"2026"},"n_packages":0,"n_references":8,"next":{"headline":"Zhonglun CloudPos JSBridge JSBridge.cs OpenLocalBrowser code injection","id":"CVE-2026-97871"},"packages":[],"prev":{"headline":"sheshbabu zen Note Editor NotesEditor.jsx dangerouslySetInnerHTML cross site scripting","id":"CVE-2026-97868"},"products":["langchain4j"],"published":"2026-09-25","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-09-25","vendors":["n/a"]},"summary":"Remote attackers can execute arbitrary code via unsafe deserialization in LangChain4j if AgenticScope persistence is enabled and the store is writable.","url":"https://insights.sbomify.com/CVE-2026-97869/"}