# CVE-2026-97896: krayin laravel-crm Upload Functionality ConfigurationForm.php rules cross site scripting

> Remote attackers can execute arbitrary scripts via the upload configuration form, potentially compromising user accounts and data.

- **Severity:** Medium 5.1 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Sep 2026
- **Updated:** 30 Sep 2026
- **Also known as:** GHSA-xwx4-qjh9-w82f

## What is CVE-2026-97896?

CVE-2026-97896 is a medium-severity cross-site scripting vulnerability in krayin laravel-crm, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A vulnerability was identified in krayin laravel-crm up to 2.2.5. This vulnerability affects the function ConfigurationForm::rules of the file packages/Webkul/Admin/src/Http/Requests/ConfigurationForm.php of the component Upload Functionality. The manipulation leads to cross site scripting. The attack is possible to be carried out remotely. The exploit is publicly available and might be used. Upgrading to version 2.2.6 is able to resolve this issue. The identifier of the patch is b9836530ec9f5ef0f51653bb0cbbc47ef7184f51. It is advisable to upgrade the affected component.

Weakness: CWE-94 (Improper Control of Generation of Code), CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-97896?


## How do I fix CVE-2026-97896?

No fix has been published for CVE-2026-97896 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-97896 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-97896 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-97896 and fix it if it is affected.

What it is: CVE-2026-97896 is a medium-severity cross-site scripting vulnerability in krayin laravel-crm, published on 25 Sep 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-97896 exists.

Affected product: krayin laravel-crm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-97896/ (Markdown: https://insights.sbomify.com/CVE-2026-97896/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-97896
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-97896
- OSV: https://osv.dev/vulnerability/CVE-2026-97896

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-97896/
Summaries are generated and may contain mistakes; the official description above is the record.
