# CVE-2026-9794: Keycloak: keycloak: information disclosure via saml ecp endpoint

> Remote attackers can identify client protocol types via SAML ECP endpoint responses, leading to information disclosure in Keycloak.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 26 Jun 2026
- **Also known as:** ECHO-4a9e-3a8a-145e, GHSA-fqjh-8322-vgrv, MINI-5pqp-cfmc-8w23, MINI-wcjj-q2cp-pvw3

## What is CVE-2026-9794?

CVE-2026-9794 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A flaw was found in Keycloak. A remote, unauthenticated attacker can exploit this vulnerability by sending specially crafted SOAP requests to the SAML ECP (Security Assertion Markup Language Enhanced Client or Proxy) endpoint with varying client IDs. By observing distinct faultstrings in the responses, the attacker can determine the client's protocol type, leading to information disclosure.

Weakness: CWE-209 (Generation of Error Message Containing Sensitive Information)

## Which versions are affected by CVE-2026-9794?

4 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.6.3 |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.6.3 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9794?

Upgrade org.keycloak:keycloak-services to 26.6.3 or later.

## Is CVE-2026-9794 being exploited?

There is no known exploitation of CVE-2026-9794 in the wild and no public exploit code.

Public exploit code:

- CVE-2026-9794 — Keycloak SAML ECP client enumeration vulnerability research (github_poc): https://github.com/MuhammedHussein17/keycloak

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9794 and fix it if it is affected.

What it is: CVE-2026-9794 is a medium-severity vulnerability in Redhat Build of Keycloak, published on 28 May 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9794 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.6.3
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9794/ (Markdown: https://insights.sbomify.com/CVE-2026-9794/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9794
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9794
- OSV: https://osv.dev/vulnerability/CVE-2026-9794

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9794/
Summaries are generated and may contain mistakes; the official description above is the record.
