# CVE-2026-9799: Keycloak: keycloak: unauthorized access to resources via uma permission ticket bypass

> Authenticated users can bypass UMA permission checks to access or modify unauthorized resources in Keycloak when PERMISSIVE mode is enabled.

- **Severity:** Medium 4.6 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 26 Jun 2026
- **Also known as:** BIT-keycloak-2026-9799, GHSA-w3p3-7cjg-vgfw

## What is CVE-2026-9799?

CVE-2026-9799 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

A flaw was found in org.keycloak.authorization. An authenticated user with a granted User-Managed Access (UMA) permission ticket for one resource can exploit this by using a specific permission request prefix to bypass per-resource access control. This allows the user to gain unauthorized access to all resources of that type within the same resource server, even if they do not have a ticket for those specific resources. This vulnerability requires the resource server to be configured in PERMISSIVE policy enforcement mode and affects typed resources with ownerManagedAccess enabled, where no explicit policy protects the resource type. The primary consequence is unauthorized information disclosure or modification of resources.

Weakness: CWE-639 (Authorization Bypass Through User-Controlled Key)

## Which versions are affected by CVE-2026-9799?

3 open source packages ship an affected version, including org.keycloak:keycloak-services and keycloak. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.13, 26.6.4 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9799?

Upgrade org.keycloak:keycloak-services to 26.6.4 or later.

## Is CVE-2026-9799 being exploited?

There is no known exploitation of CVE-2026-9799 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9799 and fix it if it is affected.

What it is: CVE-2026-9799 is a medium-severity missing authorization vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-9799 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.13, 26.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9799/ (Markdown: https://insights.sbomify.com/CVE-2026-9799/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9799
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9799
- OSV: https://osv.dev/vulnerability/CVE-2026-9799

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9799/
Summaries are generated and may contain mistakes; the official description above is the record.
