# CVE-2026-9800: Keycloak-policy-enforcer: keycloak policy enforcer: authorization bypass via incorrect uri comparison

> Authenticated users can bypass authorization policies and access protected resources by manipulating request URLs with the access-denied page path.

- **Severity:** High 8.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 25 Jun 2026
- **Updated:** 20 Oct 2026
- **Also known as:** BIT-keycloak-2026-9800, GHSA-f5p5-6xmx-p252

## What is CVE-2026-9800?

CVE-2026-9800 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A flaw was found in Keycloak Policy Enforcer. This vulnerability allows any authenticated user to bypass all authorization policies, including role, scope, and User-Managed Access (UMA) permission checks. By including the configured access-denied page path within a request URL, either as a path segment or a query parameter, an attacker can gain unauthorized access to protected resources.

Weakness: CWE-1025 (Comparison Using Wrong Factors)

## Which versions are affected by CVE-2026-9800?

5 open source packages ship an affected version, including org.keycloak:keycloak-policy-enforcer, keycloak and org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-policy-enforcer` | Maven | All versions | 26.0.10 |
| `org.keycloak:keycloak-policy-enforcer` | Maven | All versions | 26.0.10 |
| `keycloak` | Bitnami | From 26.4.0 | 26.4.13, 26.7.0 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |
| `org.keycloak:keycloak-services` | Maven | All versions | 26.6.4 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9800?

Upgrade org.keycloak:keycloak-policy-enforcer to 26.0.10 or later.

## Is CVE-2026-9800 being exploited?

There is no known exploitation of CVE-2026-9800 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9800 and fix it if it is affected.

What it is: CVE-2026-9800 is a high-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 25 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9800 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-policy-enforcer (Maven): affected all versions; fixed in 26.0.10
- org.keycloak:keycloak-policy-enforcer (Maven): affected all versions; fixed in 26.0.10
- keycloak (Bitnami): affected from 26.4.0; fixed in 26.4.13, 26.7.0
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4
- org.keycloak:keycloak-services (Maven): affected all versions; fixed in 26.6.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9800/ (Markdown: https://insights.sbomify.com/CVE-2026-9800/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9800
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9800
- OSV: https://osv.dev/vulnerability/CVE-2026-9800

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9800/
Summaries are generated and may contain mistakes; the official description above is the record.
