# CVE-2026-9802: Keycloak: keycloak: unauthorized account access via replayed refresh tokens after cluster restart

> Attackers can replay revoked refresh tokens after a cluster restart to gain unauthorized access to user accounts, requiring persistent session storage and token revocation enabled.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 May 2026
- **Updated:** 26 Jun 2026
- **Also known as:** ECHO-8c5f-67fb-cf76, GHSA-v5g5-wwmp-jppw, MINI-2qm6-rm37-8jx7, MINI-crpp-v4jv-w99g

## What is CVE-2026-9802?

CVE-2026-9802 is a medium-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A flaw was found in Keycloak. When revokeRefreshToken=true is enabled and persistent session storage is in use, a server restart can reset internal timing mechanisms. This allows a remote attacker, who has previously captured a user's refresh token, to replay that token even after it has been revoked. Successful exploitation grants the attacker unauthorized access to the victim's account, potentially leading to information disclosure or privilege escalation.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2026-9802?

4 open source packages ship an affected version, including org.keycloak:keycloak-services. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | All versions to 26.4.7 | None |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.6.3 |
| `org.keycloak:keycloak-services` | Maven | From 26.5.0 | 26.6.3 |

Products: Redhat Build of Keycloak.

## How do I fix CVE-2026-9802?

Upgrade org.keycloak:keycloak-services to 26.6.3 or later.

## Is CVE-2026-9802 being exploited?

There is no known exploitation of CVE-2026-9802 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Build of Keycloak

- [CVE-2026-15572](https://insights.sbomify.com/CVE-2026-15572/): Keycloak-services: keycloak-services: dcr protocol mapper type-swap policy bypass allows privilege escalation (high 8.8)
- [CVE-2026-3047](https://insights.sbomify.com/CVE-2026-3047/): Keycloak SAML Broken has Authentication Bypass by Primary Weakness (high 8.8)
- [CVE-2026-15573](https://insights.sbomify.com/CVE-2026-15573/): Keycloak-services: keycloak-services: authorization bypass via unnormalized uri matching in pathmatcher (high 8.1)
- [CVE-2026-16102](https://insights.sbomify.com/CVE-2026-16102/): Keycloak-services: keycloak-services: default dcr policy allows role forgery via user property mappers (high 8.1)
- [CVE-2026-1609](https://insights.sbomify.com/CVE-2026-1609/): Org.keycloak/keycloak-quarkus-server: keycloak: unauthorized access via jwt authorization grant with disabled users (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9802 and fix it if it is affected.

What it is: CVE-2026-9802 is a medium-severity authentication bypass vulnerability in Redhat Build of Keycloak, published on 28 May 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-9802 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected all versions up to 26.4.7; no fix listed
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.6.3
- org.keycloak:keycloak-services (Maven): affected from 26.5.0; fixed in 26.6.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9802/ (Markdown: https://insights.sbomify.com/CVE-2026-9802/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9802
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9802
- OSV: https://osv.dev/vulnerability/CVE-2026-9802

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9802/
Summaries are generated and may contain mistakes; the official description above is the record.
