# CVE-2026-9808: Mautic has an Authorization Bypass in API v2 Endpoints

> Low-privilege API users can bypass ownership restrictions to access or modify other users' resources in Mautic.

- **Severity:** High 7.1 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 May 2026
- **Updated:** 29 May 2026
- **Also known as:** GHSA-2jrw-c95w-h43g

## What is CVE-2026-9808?

CVE-2026-9808 is a high-severity missing authorization vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

An authorization bypass vulnerability exists in the Mautic 7 API v2 endpoints (utilizing API Platform). Under certain conditions, roles configured with owner-scope restrictions (such as `viewown` or `editown`) are not properly enforced. This allows low-privilege authenticated API users to bypass ownership-logic controls and access or modify resources belonging to other users.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-9808?

2 open source packages ship an affected version, including mautic/core.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mautic/core` | Packagist | From 7.0.0 | 7.1.2 |
| `mautic/core` | Packagist | From 7.0.0 | 7.1.2 |

## How do I fix CVE-2026-9808?

Upgrade mautic/core to 7.1.2 or later.

## Is CVE-2026-9808 being exploited?

There is no known exploitation of CVE-2026-9808 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-9808 and fix it if it is affected.

What it is: CVE-2026-9808 is a high-severity missing authorization vulnerability in mautic/core, published on 29 May 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-9808 in the wild and no public exploit code.

Affected packages and fixed versions:
- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2
- mautic/core (Packagist): affected from 7.0.0; fixed in 7.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-9808/ (Markdown: https://insights.sbomify.com/CVE-2026-9808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-9808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-9808
- OSV: https://osv.dev/vulnerability/CVE-2026-9808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-9808/
Summaries are generated and may contain mistakes; the official description above is the record.
