{"answers":{"affected":"3 open source packages ship an affected version, including rustc-serialize.","exploited":"There is no known exploitation of GHSA-2226-4v3c-cff8 in the wild and no public exploit code.","fix":"No fix has been published for GHSA-2226-4v3c-cff8 yet. Limit exposure of the affected software until one is available.","what":"GHSA-2226-4v3c-cff8 is a denial of service vulnerability in rustc-serialize, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-2226-4v3c-cff8 and fix it if it is affected.\n\nWhat it is: GHSA-2226-4v3c-cff8 is a denial of service vulnerability in rustc-serialize, published on 1 Jan 2022. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-2226-4v3c-cff8 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- rustc-serialize (crates.io): affected all versions up to 0.3.24; no fix listed\n- rustc-serialize (crates.io): affected all versions up to 0.3.24; no fix listed\n- rustc-serialize (crates.io): affected from 0.0.0-0; no fix listed\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-2226-4v3c-cff8/ (Markdown: https://insights.sbomify.com/GHSA-2226-4v3c-cff8/index.md)","id":"GHSA-2226-4v3c-cff8","markdown":"https://insights.sbomify.com/GHSA-2226-4v3c-cff8/index.md","name":"GHSA-2226-4v3c-cff8","record":{"aliases":["RUSTSEC-2022-0004"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Rust JSON library","requires_auth":"none","summary":"Attackers can cause a stack overflow and crash the application by providing deeply nested JSON input to the rustc_serialize library.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"When parsing JSON using `json::Json::from_str`, there is no limit to the depth of the stack, therefore deeply nested objects can cause a stack overflow, which aborts the process.\n\nExample code that triggers the vulnerability is\n\n```rust\nfn main() {\n    let _ = rustc_serialize::json::Json::from_str(\u0026\"[0,[\".repeat(10000));\n}\n```\n\n[serde](https://crates.io/crates/serde) is recommended as a replacement to rustc_serialize.","ecosystems":["crates.io"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":false,"headline":"Stack overflow in rustc_serialize when parsing deeply nested JSON","id":"GHSA-2226-4v3c-cff8","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"crates.io","product":null,"products":[],"type":"denial_of_service","year":"2022"},"n_packages":3,"n_references":null,"packages":[{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["0.3.24"],"package":"rustc-serialize","purl":null,"source":"GHSA-2226-4v3c-cff8"},{"ecosystem":"crates.io","fixed":[],"introduced":["0"],"last_affected":["0.3.24"],"package":"rustc-serialize","purl":"pkg:cargo/rustc-serialize","source":"GHSA-2226-4v3c-cff8"},{"ecosystem":"crates.io","fixed":[],"introduced":["0.0.0-0"],"last_affected":[],"package":"rustc-serialize","purl":"pkg:cargo/rustc-serialize","source":"RUSTSEC-2022-0004"}],"products":null,"published":"2022-01-01","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"open","licence":"CC0 1.0","name":"RustSec","prefix":"RUSTSEC"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"Attackers can cause a stack overflow and crash the application by providing deeply nested JSON input to the rustc_serialize library.","url":"https://insights.sbomify.com/GHSA-2226-4v3c-cff8/"}