{"answers":{"affected":"2 open source packages ship an affected version, including zendframework/zendframework1.","exploited":"There is no known exploitation of GHSA-229x-22xc-2f2w in the wild and no public exploit code.","fix":"Upgrade zendframework/zendframework1 to 1.11.13 or later.","what":"GHSA-229x-22xc-2f2w is a vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for GHSA-229x-22xc-2f2w and fix it if it is affected.\n\nWhat it is: GHSA-229x-22xc-2f2w is a vulnerability in zendframework/zendframework1, published on 7 Jun 2024. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of GHSA-229x-22xc-2f2w in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.13\n- zendframework/zendframework1 (Packagist): affected from 1.0.0; fixed in 1.11.13\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/GHSA-229x-22xc-2f2w/ (Markdown: https://insights.sbomify.com/GHSA-229x-22xc-2f2w/index.md)","id":"GHSA-229x-22xc-2f2w","markdown":"https://insights.sbomify.com/GHSA-229x-22xc-2f2w/index.md","name":"GHSA-229x-22xc-2f2w","record":{"aliases":[],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["data_read","other"],"network_reachable":"yes","non_default_config":false,"product_category":"PHP XML-RPC library","requires_auth":"none","summary":"An attacker can exploit XXE injection in Zend_XmlRpc to read arbitrary files or initiate TCP connections via crafted XML-RPC requests.","user_interaction":"not_required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":null,"cpe":[],"cvss":{"score":null,"severity":null,"source":null,"vector":null,"version":null},"cwes":[],"description":"Zend_XmlRpc is vulnerable to XML eXternal Entity (XXE) Injection attacks. The SimpleXMLElement class (SimpleXML PHP extension) is used in an insecure way to parse XML data. External entities can be specified by adding a specific DOCTYPE element to XML-RPC requests. By exploiting this vulnerability an application may be coerced to open arbitrary files and/or TCP connections.","ecosystems":["Packagist"],"exploits":{"exploitdb":null,"first_seen":null,"github_poc":null,"max_poc_stars":null,"metasploit":null,"nuclei":null,"refs":[],"tier":null},"has_fix":true,"headline":"Zendframework Local file disclosure via XXE injection in Zend_XmlRpc","id":"GHSA-229x-22xc-2f2w","indexable":true,"kev":null,"kind":"advisory","links":{"ecosystem":"Packagist","product":null,"products":[],"type":"xxe","year":"2024"},"n_packages":2,"n_references":null,"packages":[{"ecosystem":"Packagist","fixed":["1.11.13"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":null,"source":"GHSA-229x-22xc-2f2w"},{"ecosystem":"Packagist","fixed":["1.11.13"],"introduced":["1.0.0"],"last_affected":[],"package":"zendframework/zendframework1","purl":"pkg:composer/zendframework/zendframework1","source":"GHSA-229x-22xc-2f2w"}],"products":null,"published":"2024-06-07","related":[],"sources":[{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":null,"updated":null,"vendors":null},"summary":"An attacker can exploit XXE injection in Zend_XmlRpc to read arbitrary files or initiate TCP connections via crafted XML-RPC requests.","url":"https://insights.sbomify.com/GHSA-229x-22xc-2f2w/"}