# GHSA-22h7-7wwg-qmgg: Prototype Pollution in @hapi/hoek


- **Severity:** Not scored
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 4 Sep 2020

## What is GHSA-22h7-7wwg-qmgg?

GHSA-22h7-7wwg-qmgg is a vulnerability in @hapi/hoek, published on 4 Sep 2020. 

### Official description

Versions of `@hapi/hoek` prior to 8.5.1 and 9.0.3 are vulnerable to Prototype Pollution. The `clone` function fails to prevent the modification of the Object prototype when passed specially-crafted input. Attackers may use this to change existing properties that exist in all objects, which may lead to Denial of Service or Remote Code Execution in specific circumstances.  
This issue __does not__ affect hapi applications since the framework protects against such malicious inputs. Applications that use `@hapi/hoek` outside of the hapi ecosystem may be vulnerable.

## Recommendation

Update to version 8.5.1, 9.0.3 or later.

## Which versions are affected by GHSA-22h7-7wwg-qmgg?

4 open source packages ship an affected version, including @hapi/hoek.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@hapi/hoek` | npm | From 8.3.2 | 8.5.1 |
| `@hapi/hoek` | npm | From 8.3.2 | 8.5.1 |
| `@hapi/hoek` | npm | From 9.0.0 | 9.0.3 |
| `@hapi/hoek` | npm | From 9.0.0 | 9.0.3 |

## How do I fix GHSA-22h7-7wwg-qmgg?

Upgrade @hapi/hoek to a fixed version for your release line: 8.5.1 or 9.0.3.

## Is GHSA-22h7-7wwg-qmgg being exploited?

There is no known exploitation of GHSA-22h7-7wwg-qmgg in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for GHSA-22h7-7wwg-qmgg and fix it if it is affected.

What it is: GHSA-22h7-7wwg-qmgg is a vulnerability in @hapi/hoek, published on 4 Sep 2020. 
Exploitation: There is no known exploitation of GHSA-22h7-7wwg-qmgg in the wild and no public exploit code.

Affected packages and fixed versions:
- @hapi/hoek (npm): affected from 8.3.2; fixed in 8.5.1
- @hapi/hoek (npm): affected from 8.3.2; fixed in 8.5.1
- @hapi/hoek (npm): affected from 9.0.0; fixed in 9.0.3
- @hapi/hoek (npm): affected from 9.0.0; fixed in 9.0.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/GHSA-22h7-7wwg-qmgg/ (Markdown: https://insights.sbomify.com/GHSA-22h7-7wwg-qmgg/index.md)
```

## Sources

- OSV: https://osv.dev/vulnerability/GHSA-22h7-7wwg-qmgg

---
From sbomify Insights: https://insights.sbomify.com/GHSA-22h7-7wwg-qmgg/
Summaries are generated and may contain mistakes; the official description above is the record.
