GHSA-23px-mw2p-46qm Cosmos-SDK Cosmovisor component may be vulnerable to denial of service

Not scored Published

Attackers can cause denial of service or remote code execution on Cosmos validators using vulnerable Cosmovisor versions, especially with binary downloads enabled.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is GHSA-23px-mw2p-46qm?

GHSA-23px-mw2p-46qm is a denial of service vulnerability in github.com/cosmos/cosmos-sdk, published on 6 Sep 2023. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Component: Cosmovisor Criticality: Medium Affected Versions: Cosmovisor < v1.0.0 (distributed with Cosmos-SDK < 0.46) Affected Users: Validators and Node operators utilizing unsupported versions of Cosmovisor Impact: DOS, potential RCE on node depending on configuration

An issue has been identified on unsupported versions of Cosmovisor which may result in a Denial of Service or Remote Code Execution path depending on configuration for a node or validator using the vulnerable version to manage their node.

If a validator is utilizing an affected version of Cosmovisor with DAEMON_ALLOW_DOWNLOAD_BINARIES set to true, a non-default configuration, it may be possible for an attacker to trigger a Remote Code Execution path as well on the host. In this configuration it is recommended to immediately stop use of the DAEMON_ALLOW_DOWNLOAD_BINARIES feature, and then proceed with an upgrade of Cosmovisor.

It is recommended that all validators utilizing unsupported versions of Cosmovisor to upgrade to the latest supported versions immediately. If you are utilizing a forked version of Cosmos-SDK, it is recommended to stop use of Cosmovisor until it is possible to update to a supported version of Cosmovisor, whether through your project’s fork, or directly compiled from the Cosmos-SDK. At the time of this advisory, the latest version of Cosmovisor is v1.5.0.

Additionally, the Amulet team recommends that developers building chains powered by Cosmos-SDK share this advisory with validators and node operators to ensure this information is available to all impacted parties within their ecosystems.

For more information about Cosmovisor, see https://docs.cosmos.network/main/tooling/cosmovisor

This issue was discovered by Maxwell Dulin and Nathan Kirkland, who reported it to the Cosmos Bug Bounty Program. If you believe you have found a bug in the Interchain Stack or would like to contribute to the program by reporting a bug, please see https://hackerone.com/cosmos.

How to tell if I am affected?

Running the following command will output whether your cosmovisor version is vulnerable to this issue or not.

Vulnerable to this issue:

strings ./cosmovisor | grep -q &#34;NEEDED at&#34; &amp;&amp; echo &#34;vulnerable&#34; || echo &#34;NOT vulnerable&#34;

vulnerable

NOT vulnerable to this issue:

strings ./cosmovisor_new | grep -q &#34;NEEDED at&#34; &amp;&amp; echo &#34;vulnerable&#34; || echo &#34;NOT vulnerable&#34;

NOT vulnerable

A Note from Amulet on the Security Advisory Process

In the interest of timely resolution of this issue for validators and node operators, the Amulet team has chosen to use existing processes and resources for distributing security advisories within the Cosmos and Interchain Ecosystems. Stay tuned as we implement an improved, more robust security advisory distribution system that will provide equitable access to information about security issues in the Interchain Stack.

Which versions are affected by GHSA-23px-mw2p-46qm?

2 open source packages ship an affected version, including github.com/cosmos/cosmos-sdk.

PackageAffectedFixed in
github.com/cosmos/cosmos-sdk GoAll versions0.46
github.com/cosmos/cosmos-sdk GoAll versions0.46

How do I fix GHSA-23px-mw2p-46qm?

Upgrade github.com/cosmos/cosmos-sdk to 0.46 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is GHSA-23px-mw2p-46qm being exploited?

There is no known exploitation of GHSA-23px-mw2p-46qm in the wild and no public exploit code.

Sources

Is GHSA-23px-mw2p-46qm in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free